DSCP Settings and Terminology

Several DiffServ RFCs suggest a set of values to use in the DSCP field and an implied meaning for those settings. For instance, RFC 2598 defines a DSCP of decimal 46, with a name Expedited Forwarding (EF). According to that RFC, packets marked as EF should be given queuing preference so that they experience minimal latency, but the packets should be policed to prevent them from taking over a link and preventing any other types of traffic from exiting an interface during periods when this high-priority traffic reaches or exceeds the interface bandwidth. These suggested settings, and the associated QoS behavior recommended when using each setting, are called Per-Hop Behaviors (PHBs) by DiffServ. (The particular example listed in this paragraph is called the Expedited Forwarding PHB.)
The Class Selector PHB and DSCP Values
IPP overlaps with the first 3 bits of the DSCP field because the DS field is simply a redefinition of the original ToS byte in the IP header. Because of this overlap, RFC 2475 defines a set of DSCP values and PHBs, called Class Selector (CS) PHBs, that provide backward compatibility with IPP. A C&M feature can set a CS DSCP value, and if another router or switch just looks at the IPP field, the value will make sense from an IPP perspective. Table 14-3 lists the CS DSCP names and values, and the corresponding IPP values and names.
Table 14-3 Default and Class Selector DSCP Values
KEY POINT
Table 14-3 Default and Class Selector DSCP Values
|
DSCP Class Selector Names |
Binary DSCP Values |
IPP Binary Values |
IPP Names |
|
Default/CS0* |
000000 |
000 |
Routine |
|
CS1 |
001000 |
001 |
Priority |
|
CS2 |
010000 |
010 |
Immediate |
|
CS3 |
011000 |
011 |
Flash |
|
CS4 |
100000 |
100 |
Flash Override |
|
CS5 |
101000 |
101 |
Critic/Critical |
|
CS6 |
110000 |
110 |
Internetwork Control |
|
CS7 |
111000 |
111 |
Network Control |
*The terms "CS0" and "Default" both refer to a binary DSCP of 000000, but most Cisco IOS commands allow only the keyword "default" to represent this value.
*The terms "CS0" and "Default" both refer to a binary DSCP of 000000, but most Cisco IOS commands allow only the keyword "default" to represent this value.
Besides defining eight DSCP values and their text names, the CS PHB also suggests a simple set of QoS actions that should be taken based on the CS values. The CS PHB simply states that packets with larger CS DSCPs should be given better queuing preference than packets with lower CS DSCPs.
The Assured Forwarding PHB and DSCP Values
The Assured Forwarding (AF) PHB (RFC 2597) defines four classes for queuing purposes, along with three levels of drop probability inside each queue. To mark packets and distinguish into which of four queues a packet should be placed, along with one of three drop priorities inside each queue, the AF PHB defines 12 DSCP values and their meanings. The names of the AF DSCPs conform to the following format:
AFxy
where x implies one of four queues (values 1 through 4), and y implies one of three drop priorities (values 1 through 3).
The AF PHB suggests that the higher the value of x in the DSCP name AFxy, the better the queuing treatment a packet should get. For example, packets with AF11 DSCPs should get worse queuing treatment than packets with AF23 DSCP values. Additionally, the AF PHB suggests that the higher the value of y in the DSCP name AFxy, the worse the drop treatment for those packets. (Treating a packet worse for drop purposes means that the packet has a higher probability of being dropped.) For example, packets with AF11 DSCPs should get better drop treatment than packets with AF23 DSCP values. Table 14-4 lists the names of the DSCP values, the queuing classes, and the implied drop likelihood.
Table 14-4 Assured Forwarding DSCP Values—Names, Binary Values, and Decimal Values
KEY
POINT
Table 14-4 Assured Forwarding DSCP Values—Names, Binary Values, and Decimal Values
|
Queue Class |
Low Drop Probability |
Medium Drop Probability |
High Drop Probability |
|
Name/Decimal/Binary |
Name/Decimal/Binary |
Name/Decimal/Binary |
|
|
1 |
AF11 / 10 / 001010 |
AF12 / 12 / 001100 |
AF13 / 14 / 001110 |
|
2 |
AF21 / 18 / 010010 |
AF22 / 20 / 010100 |
AF23 / 22 / 010110 |
|
4 |
AF31 / 26 / 011010 |
AF32 / 28 / 011100 |
AF33 / 30 / 011110 |
|
5 |
AF41 / 34 / 100010 |
AF42 / 36 / 100100 |
AF43 / 38 / 100110 |
The text AF PHB names do not follow the "bigger-is- better" logic in all cases. For example, the name AF11 represents a decimal value of 10, and the name AF13 represents a decimal DSCP of 14. However, AF11 is "better" than AF13, because AF11 and AF13 are in the same queuing class, but AF11 has a lower probability of being dropped than AF13.
The binary version of the AF DSCP values shows the patterns of the values. The first 3 bits of the binary DSCP values imply the queuing class (bits 0 through 2), and the next 2 bits (bits 3 and 4) imply the drop preference. As a result, queuing tools that operate only on IPP can still react to the AF DSCP values, essentially making the AF DSCPs backward compatible with non-DiffServ nodes for queuing purposes.
KEY POINT
NOTE To convert from the AF name to the decimal equivalent, you can use a simple formula. If you think of the AF values as AFxy, the formula is:
8x + 2y = decimal value
For example, AF41 gives you a formula of (8 * 4) + (2 * 1) = 34.
The Expedited Forwarding PHB and DSCP Values
RFC 2598 defines the Expedited Forwarding (EF) PHB, which was described briefly in the introduction to this section. This RFC defines a very simple pair of PHB actions:
■ Queue EF packets so that they get scheduled quickly, to give them low latency.
■ Police the EF packets so that they do not consume all bandwidth on the link or starve other queues.
The DSCP value defined for EF is named EF, with decimal value 46, binary value 101110.
Continue reading here: Software Queues and Hardware Queues
Was this article helpful?
Readers' Questions
-
Kaija Kirvesniemi1 year ago
- Reply