InterVLAN Communication on a Multilayer Switch Through a Switch Virtual Interface

Rather than using an external router to provide inter-VLAN communication, a multilayer switch can perform the same task through the use of a switched virtual interface (SVI).

Removing L2 Switchport Capability of a Switch Port

3560Switch(config)#interface fastethernet 0/1

Moves to interface configuration mode

3560Switch(config-if)#no switchport

Creates a Layer 3 port on the switch

NOTE: The no switchport command can be used on physical ports only.

Configuring Inter-VLAN Communication

3560Switch(config)#interface vlan 1

Creates a virtual interface for VLAN 1 and enters interface configuration mode

3550Switch(config-if)#ip address 172.16.1.1 255.255.255.0

Assigns IP address and netmask

3550Switch(config-if)#no shutdown

Enables the interface

3550Switch(config)#interface vlan 10

Creates a virtual interface for VLAN 10 and enters interface configuration mode

3550Switch(config-if)#ip address 172.16.10.1 255.255.255.0

Assigns IP address and netmask

3550Switch(config-if)#no shutdown

Enables the interface

3550Switch(config)#interface vlan 20

Creates a virtual interface for VLAN 20 and enters interface configuration mode

3550Switch(config-if)#ip address 172.16.20.1 255.255.255.0

Assigns IP address and netmask

3550Switch(config-if)#no shutdown

Enables the interface

3550Switch(config-if)#exit

Returns to global configuration mode

3550Switch(config)#ip routing

Enables routing on the switch

NOTE: The subnets of the VLANs are directly connected to the switch. Routing between these subnets does not require a dynamic routing protocol. If the switch is to be connected to a router and remote communication is desired, a routing protocol must be enabled and networks advertised:

3560Switch(config)#router eigrp 1

3560Switch(config-router)#network 172.16.0.0

3560Switch(config-router)#exit

3560Switch(config)#

Was this article helpful?

0 0

Post a comment