Case Study Route Tagging

Figure 14.17 shows a situation in which routes from several routing domains, each running a separate routing protocol, are being redistributed into a single transit domain running OSPF. On the other side of the OSPF cloud, the routes must be redistributed back into their respective domains. Route filters can be used at the egress points from the OSPF cloud into each domain to permit only the routes that belong to that domain. However, if each domain has many routes or if the routes within the domain change frequently, the route filters can become difficult to manage

Figure 14.17. Routes from each of the three domains on the left are redistributed into a transit internetwork running OSPF. On the right, the routes for each domain must be redistributed back into their original domains.

Figure 14.17. Routes from each of the three domains on the left are redistributed into a transit internetwork running OSPF. On the right, the routes for each domain must be redistributed back into their original domains.

Another way of handling this problem is to tag the routes at their ingress points to the OSPF transit domain with a tag that is unique to each domain. At the egress points, the routes can be redistributed by their tags instead of by specific addresses. The routing protocol of the transit network does not use the tag, but merely conveys it to and from its external networks. RIPv2, EIGRP, Integrated IS-IS and OSPF all support route tags. BGP also supports route tags. Tags are not supported by RIPv1 or IGRP.

A reexamination of the packet formats in Chapters 7, "Routing Information Protocol," 8, "Enhanced Interior Gateway Routing Protocol (EIGRP)," and 9, "Open Shortest Path First," show that RIPv2 messages support 16-bit tags, whereas EIGRP external route TLVs and OSPF type 5 LSAs support 32-bit tags. These tags are expressed as decimal numbers, so tags carried by RIPv2 will be between 0 and 65,535, and tags carried by EIGRP and OSPF will be between 0 and 4,294,967,295.

In Figure 14.18, router Dagwood is accepting routes from three different routing domains and redistributing them into a domain running OSPF. The objective here is to tag the routes from each domain so that their source domain may be identified within the OSPF cloud. Routes from domain 1 will have a tag of 1, domain 2 will have a tag of 2, and so on.

Figure 14.18. Dagwood is configured to tag the routes from each of the three routing domains as they are redistributed into OSPF.

Figure 14.18. Dagwood is configured to tag the routes from each of the three routing domains as they are redistributed into OSPF.

Dagwood's configuration is:

router ospf 1 redistribute igrp 1 metric 10 subnets tag 1 redistribute rip metric 10 subnets route-map Dithers network 10.100.200.1 0.0.0.0 area 0 !

router rip network 10.0.0.0

router igrp 1 network 10.0.0.0

access-list 1 permit 10.1.2.3

access-list 2 permit 10.1.2.4 !

route-map Dithers permit 10 match ip route-source 1 set tag 2 !

route-map Dithers permit 20 match ip route-source 2 set tag 3

First, notice the redistribute igrp command under OSPF. Dagwood is accepting routes from only one IGRP domain, so the tag can be set to 1 directly on the redistribute command. However, routes are being learned from two RIP domains. Here a route map is needed. Route map Dithers sets the tag of the RIP routes to either 2 or 3, depending on whether the route was learned from Funky (10.1.2.3) or Beetle (10.1.2.4). Figure 14.19 shows an LSA advertising one of the RIP-learned routes, with the route tag set to 2. The route tags can also be observed in the OSPF link state database (Figure 14.20).

Figure 14.19. This type 5 LSA is advertising network 192.168.2.0, which is in domain 2, within the OSPF

domain. The route tag is shown on the last line.

Figure 14.19. This type 5 LSA is advertising network 192.168.2.0, which is in domain 2, within the OSPF

domain. The route tag is shown on the last line.

Figure 14.20. The OSPF link state database indicates the tags that were set for each of the external routes by Dagwood's redistribution processes.

Blondletfshow ip osai database ospi Router w±tn 10 (10.100.200.2) (Process id ■)

flou ter Liok States (A'-ca Hi Link lü ADV Houtar A'jo Soq* C hack suai Liok cûuM

10.100.200.2 ia.iM.aea,2 as 0x00000002 ûxsffs \

10.100.290.1 10.100.200.1 40 0XM000033 0*3311 1

Nil Link Stales (Area 0)

Link ID AUv Router Age üoq^ Checksum

10.100.200.1 10. 1 CM. 200. 1 10 0*80000001 flxliW

AS External Link S.t 1ü

Link ID

AUV Router

Ago

Seqa

Checks Lin

lag

192.168.2.0

10.100.200,

,1

641

0XÎÎBOH00Ï8

0X904D

2

1n.17.7r.tf

10,100..1

642

0x50000023

0KC017

3

192.168.3.0

10.1 OH.200

, 1

G42

0*fl«H1002a

3

1 e T -t 5.75. a

10r100.20a,

,1

642

0X00000028

0xD2i3

1

10.1.2.0

10.100.200.

, 1

642

s*HAana02s

1

1o, 16.7Ê.a

10.100.20a.

,1

0x50000020

2

192.168-1.0

10.100.200.

.1

644

0x8956

1

10 ,100.200.0

10,10H,200

,1

0XGEA4

1

Blondie*

In Figure 14.21, Blondie must redistribute only domain 2 routes to Alley and only domain 1 routes to Oop. Because the routes were tagged as they entered the OSPF transit domain, this is easily done:

Figure 14.21. Blondie is using route maps to redistribute routes according to their route tag.

Figure 14.21. Blondie is using route maps to redistribute routes according to their route tag.

router ospf 1

router rip redistribute ospf 1 match external 2 route-map Daisy passive-interface Ethernet0

passive-interface Serial1

network 10.0.0.0

default-metric 5

router ospf 1

router rip redistribute ospf 1 match external 2 route-map Daisy passive-interface Ethernet0

passive-interface Serial1

network 10.0.0.0

default-metric 5

router igrp 1 redistribute ospf 1 match external 2 route-map Herb passive-interface Ethernet0 passive-interface Serial0 network 10.0.0.0

default-metric 10000 1000 255 1 1500

route-map Daisy permit 10 match tag 2

route-map Herb permit 10 match tag 1

Figure 14.22 shows the resulting routes at Alley and Oop. One drawback to the use of route tags to filter routes is that there is no way to filter routes by interface. For example, if Blondie had to send routes to both domain 2 and domain 3, which both run RIP, route maps cannot be configured to send some routes to one RIP process and other routes to another RIP process. The routes would have to be filtered by address with distribute-list commands.

Figure 14.22. The route tables of Alley and Oop in Figure 14.21 show the results of the redistribution configuration at Blondie.

Figure 14.22. The route tables of Alley and Oop in Figure 14.21 show the results of the redistribution configuration at Blondie.

: 14.1,3.0 [1W/1Î47&1 v * .a 14.1.4.1, Serial«

: -z. lüe.üwä.e MH/fiäre; via 10.1.4.1, eu : ¡w :ïû. serial«

I îaï.iea.i.i |ift«/ei76] via 10.1,4.1, Serial«

Was this article helpful?

0 0

Post a comment