Answers to Chapter 1 Configuration Exercises

1 Autonomous System 65531 m Figure 1-14 is a core AS.

Figure 1-14 The Internetwork for Configuration Exercise 1

Figure 1-14 The Internetwork for Configuration Exercise 1

RTA interface

Address

EO

192.168.1.1/24

SO

192.168.2.1/24

S1

192.168.3.1/24

S2

192.168.4.1/24

RTB interface

Address

EO

192.168.1.2/24

SO

192.168.5.1/24

Configure EGP on RTA and RTB, with the following constraints:

— The data link interior to the AS is not advertised to any exterior neighbor.

— RTA advertises the network attached to its SI interface to RTB; with this exception, no other inter-AS link is advertised between RTA and RTB.

— RTA and RTB advertise a default route to their extenor neighbors in addition to networks learned from oth^ autonomous systems. Neither gateway advertises a default route to its internal neighbor.

Answer* The configurations of RTA and RTB are as follows: hostname RTA

interface EthernetO ip address 192.168.1 1 255.255.255.0

interface SerialO ip address 192.168.2.1 255.255.255.0

interface Seriall ip address 192.168.3.1 255.255.255.0

interface Senal2 ip address 192.168.4.1 255.255.255.0

autonomous-system 65531

router egp 0 network 192.168.3.0 neighbor 192.168.1.2 neighbor any default information originate distribute-list 1 out Ethernet0

access-list 1 deny 0.0.0.0

access-list 1 permit any hostname RTB

interface Ethernet0 ip address 192.168.1.2 255.255.255.0

interface SerialO ip address 192.168.5.1 255.255.255.0

autonomous-system 65531

router egp 0 neighbor any default information originate distribute-list 1 out Ethernet0

access list 1 deny 0 0 0 0 access list 1 permit any

2 Example 1 26 shows the route table of RTC in Figure 115 Example 2 26 The Route Table of RTC in Figure 1 15

RTC#show ip route

Codes: C connected S static I IGRP R RIP M mobile B BGP D EIGRP EX EIGRP external 0 OSPF IA 0SPF inter area E1 OSPF external type 1 E2 OSPF external type 2 E EGP i IS IS L1 IS IS level 1 L2 IS IS level 2 candidate default

Gateway of last resort is not set

I 192 168 105 0 [100/8976] via 192 168 6 2 00:01:00 Seriall I 192 168 110 0 [100/8976] via 192 168 6 2 00:01:00 Seriall I 192 168 100 0 [100/8976] via 192 168 10 2 00:01:00 Serial2 I 192 168 120 0 [100/8976] via 192 168 10 2 00:01:01 Serial2 C 192 168 2 0 is directly connected Serial© C 192 168 6 0 is directly connected Seriall C 192 168 10 0 is directly connected Serial2 RTC#

Figure 1 15 The Internetwork for Configuration Exercise 2

Figure 1 15 The Internetwork for Configuration Exercise 2

Using redistribution, configure RTC to advertise all EGP-learned networks into AS 65510, and all internal networks except 192.168.105.0 to the core AS. Protect against route feedback by ensuring that none of the networks internal to AS 65510 are advertised back via EGP. The process ID in this configuration is the same as the local AS number.

Answer* The relevant configuration of RTC is as follows:

-4-

autonomous-system 65510

router igrp 65510

redistribute egp 65531 metric 1544 1(

)0 255 1 1500

network 192.168.6.0

router egp 65531

redistribute igrp 65510

neighbor 192.168.2.1

distribute-list 10 out Senal0

distribute-list 20 in Serial0

access-list 10 deny 192.168.105.0

access-list 10 permit any

access-list 20 deny 192.168.105.0

access-list 20 deny 192.168.110.0

access-list 20 deny 192.168.100.0

access-list 20 deny 192.168.120.0

access-list 20 deny 192.168.10.0

access-list 20 deny 192.168.6.0

access-list 20 permit any

Notice that no metric is specified for the redistribution into EGP* EGP adds a default metric of 3. In this example, the distribute-list command is used to filter routes, although a route map could also be used for the same purpose. Of particular interest is the filter that blocks internal network addresses if they are included in incoming EGP updates. Even though 192.168.105.0 is not being advertised out of the AS, the address is included in access list 20. This guards against the possibility of the network's finding its way into the EGP domain by some other means and then being routed back into AS 65510. It also guards against the possibility of a duplicate network address entering the AS.

3 Example 1-27 shows the route table of RTD in Figure 1-15.

Example 1-27 The Route Table of RTD in Figure 1-15 RTD#show lp route

Codes: C connected, S static, I IGRP R RIP M mobile, B BGP D EIGRP EX EIGRP external, 0 0SPF IA 0SPF inter area E1 0SPF external type 1 E2 0SPF external type 2, E EGP i IS-IS, L1 IS-IS level 1 L2 IS^IiTlfcYel-2, candidate default

Example 1 27 The Route Table ofRTD in Figure 1 15 (Continued) Gateway of last resort is not set

C 192 168 3 0 is directly connected Serial©

C 192 168 7 0 is directly connected Seriall

Configure RTD with the following parameters:

— Only 192 168 220 0 and 192 168 230 0 are to be advertised to AS 65531

— No routing protocol is redistributed into EGP

— EGP is redistributed into the IGP of AS 65515

— 192 168 3 0 is advertised into AS 65515 with a metric of 1

— 192 168 100 0 from RTC is advertised into AS 65515 with a metric of 1

— 192 168 120 0 from RTC is advertised into AS 65515 with a metric of 3

— All other routes are advertised into AS 65515 with a metric of 5

Answer: The relevant configuration of RTD is as follows:

autonomous system 65515 i

router rip

redistribute egp 65531 route

map EXTERNAL

network 192 168 7 0

network 192 168 3 0

i

router egp 65531

network 192 168 220 0

network 192 168 230 0

f

access list 10 permit 192 168

100 0

access list 20 permit 192 168

120 0

access list 30 permit any i

route map EXTERNAL permit 10

match ip address 10

i

route map EXTERNAL permit 20

match ip address 20

i

route map EXTERNAL permit 30

match ip address 30

Seriall Seriall Seriall Seriall

4 Example 1-28 shows the route table of RTE in Figure 1-15. Example 1-28 The Route Table of RTE in Figure 1-15

RTE#show ip route

Codes.

connected, S static, I IGRP R RIP EIGRP EX EIGRP external, 0 OSPF IA

M mobile, B BGP OSPF inter area

OSPF NSSA external type 1 OSPF external type 1 E2 IS-IS, L1 IS-IS level 1 per-user static route, o

N2 OSPF NSSA external type 2 OSPF Eternal type 2, E EGP L2 IS-IS level 2, candidate default 0DR

Gateway of last resort is not set

0 192.168.125.0/28 [110/74] via 192.168.130.6, 00:01:03, Senall C 192.168.4.0/24 is directly connected, Serial©

192.168.225.0/28 is subnetted, 1 subnets 0 E2 192.168.225.160 [110/50] via 192.168.130.18, 00:01:04 Ethernet©

192.168.215.0/24 is variably subnetted, 3 subnets, 3 masks 0 192.168.215.161/32 [110/65] via 192.168.130.6, 00:01:04 Senall

0 E2 192.168.215.192/26 [110/50] via 192.168.130.18, 00:01:04 Ethernet© 0 E1 192.168.215.96/28 [110/164] via 192.168.130.6, 00:01:04 Seriall

192.168.130.0/24 is variably subnetted, 7 subnets, 4 masks D 192.168.131 192/27 [90/2195456] via 192.168.130.6, 00:16:49, Senall

D 192.168.131.96/27 [90/409600] via 192.168.130.18, 00:16:49, Ethernet©

0 192.168.131.97/32 [110/11] via 192.168.130.18, 00:01:05, Ethernet©

D 192.168.131.64/27 [90/409600] via 192.168.130.18, 00:15:01 Ethernet©

D 192.168.131.8/30 [90/2195456] via 192.168.130.6, 00:16:49 Seriall

C 192.168.131 4/30 is directly connected, Senall c 192.168.131 16/28 is directly connected, Ethernet©

RTE#

Configure RTE with the following parameters:

— No IGP is redistributed into EGR

— EGP is not redistributed into any IGP.

— All the internal networks of AS 65520 are advertised to AS 65531.

— The internal routers of AS 65520 can forward packets to any network advertised by RTA.

— All process IDs are the same as the AS number.

— All OSPF interfaces are in area 0.

Answer* The relevant configuration of RTE is as follows:

autonomous-system 65520

router eigrp 65520 redistribute static network 192.168.130.0

default metric 1000 100 255 1 1500 no auto summary

router ospf 65520

redistribute static metric 10 subnets network 192 168 130 4 0 0 0 3 area 0 network 192 168 130 16 0 0 0 15 area 0

router egp 65531 network 192 168 125 0 network 192 168 131 0 network 192 168 215 0 network 192 168 225 0 neighbor 192 168 4 1

5 In Figure 1 16 AS 65525 has been added to the internetwork of the previous exercises RTF s Ethernet interface has an IP address of 192 168 1 3/24

Figure 1 16 The Internetwork for Configuration Exercise 5

Figure 1 16 The Internetwork for Configuration Exercise 5

Configure this router to peer only with RTB, and make any necessary configuration changes to support third-party neighbors.

Answer* The configurations of RTF and RTB are as follows:

RTF

autonomous-system 65525

router egp 65531

%

network 192.168.50.0

neighbor 192.168.1.2

RTB

autonomous-system 65531

router egp 0

neighbor 192.168.1 1

neighbor 192.168.1 1 third-party

192.168.1.3 external

neighbor 192.168.1.3

neighbor 192.168.1.3 third-party

192.168.1 1

neighbor any

default information originate

distribute-list 1 out Ethernet0

access-list 1 deny 0.0.0.0

access-list 1 permit any

Answers to Chapter 3 Configuration Exercises

Table 3-4 shows the routers and addresses used for Configuration Exercises 1-13. Table 3-4 Routers/Addresses for Configuration Exercises 1-13

Autonomous System

Router

Interface

IP Address/Mask

1

R1

LO

10.255.255.1/32

SO

192.168.100.1/30

EO

192.168.100.5/30

El

192.168.100.13/30

R2

LO

10.255.255.2/32

SO

192.168.100.9/30

\

xsi

192.168.100.57/30

*

192.168.100.6/30

El

192.168.100.17/30

Table 3 4 Routers/Addresses for Configuration Exercises 1-13 (Continued)

Autonomous System

Router

Interface

IP Address/Mask

1 (continued)

R3

LO

10 255 255 3/32

SO

192 168 100 25/30

EO

192 168 100 18/30

El

192 168 100 21/30

R4

LO

10 255 255 4/32

SO

192 168 100 29/30

SI

192 168 100 33/30

EO

192 168 100 22/30

El

192 168 100 14/30

2

R5

SO

192 168 100 2/30

EO

192 168 1 129/26

R6

SO

192 168 100 10/30

EO

192 168 1 130/26

3

R7

LO

10 255 255 7/32

SO

192 168 100 26/30

SI

192 168 100 41/30

EO

192 168 100 37/30

El

172 16 1 1/24

4

R8

LO

10 255 255 8/32

SO

192 168 100 30/30

SI

192 168 100 45/30

EO

192 168 100 38/30

El

172 16 2 1/24

continues continues

Table 3-4 Routers/Addresses for Configuration Exercises 1-13 (Continued)

Autonomous System

Router

Interface

IP Address/Mask

5

R9

LO

10.255.255.9/32

SO

192.168.100.42/30

EO

%

192.168.9.1/24

El

192.168.150.1/24

RIO

LO

10.255.255.10/32

SO

192.168.100.46/30

EO

192.168.10.1/24

El

192.168.100.53/30

E2

192.168.150.2/24

Rll

LO

10.255.255.11/32

SO

192.168.100.34/30

EO

192.168.100.54/30

El

192.168.11.1/24

6

R12

LO

192.168.255.1/32

SO

192.168.100.58/30

EO

192.168.16.83/27

Table 3-4 lists the autonomous systems, routers, interfaces, and addresses used in Configuration Exercises 1-13. All interfaces of the routers are shown. For each exercise, if the table indicates that the router has a loopback interface, that interface should be the source of all IBGP connections. EBGP connections should always be between physical interface addresses unless otherwise specified m the exercise. Hint: Draw the internetwork, based on the subnets listed in the table, before attempting the exercises.

1 AS 1 in Table 3-4 is a transit AS, and the IGP is OSPF Area 0 spans the entire AS. No networks internal to the AS are advertised outside of the AS. None of the subnets over which EBGP are run should be advertised into AS 1. Write BGP configurations for the routers in AS 1, putting all internal neighbors in a peer group called LOCAL. For R3 only, EBGP peering should be performed between loopback interfaces. Authenticate all IBGP connections with the password ExeRCisel.

Answer:

router ospf 1 network 10 255 255 10 0 0 0 area 0 network 192 168 100 5 0 0 0 0 area 0 network 192 168 100 13 0 0 0 0 area 0

i router bgp 1 neighbor LOCAL peer group neighbor LOCAL remote as 1

neighbor LOCAL password 7 15371309360922372D62 neighbor LOCAL update source Loopback0 neighbor LOCAL next hop self neighbor 10 255 255 2 peer group LOCAL neighbor 10 255 255 3 peer group LOCAL neighbor 10 255 255 4 peer group LOCAL neighbor 192 168 100 2 remote as 2

router ospf 1 network 10 255 255 2 0 0 0 0 area 0 network 192 168 100 6 0 0 0 0 area 0 network 192 168 100 17 0 0 0 0 area 0

i router bgp 1 neighbor LOCAL peer group neighbor LOCAL remote as 1

neighbor LOCAL password 7 15371309360922372D62 neighbor LOCAL update source Loopback0 neighbor LOCAL next hop self neighbor 10 255 255 1 peer group LOCAL neighbor 10 255 255 3 peer group LOCAL neighbor 10 255 255 4 peer group LOCAL neighbor 192 168 100 10 remote as 2 neighbor 192 168 100 58 remote as 6

router ospf 1 network 10 255 255 3 0 0 0 0 area 0 network 192 168 100 18 0 0 0 0 area 0 network 192 168 100 21 0 0 0 0 area 0

router bgp 1 neighbor LOCAL peer group neighbor LOCAL remote as 1

neighbor LOCAL password 7 15371309360922372D62 neighbor LOCAL update source Loopback0 neighbor LOCAL next hop self neighbor REMOTE peer group neighbor REMOTE ebgp multihop 2 neighbor REMOTE update source Loopback0

(Continued) neighbor 10.255.255.1 peer-group LOCAL neighbor 10.255.255.2 peer-group LOCAL neighbor 10.255.255.4 peer-group LOCAL neighbor 192.168.100.26 peer-group REMOTE neighbor 192.168.100.26 remote-as 3

router ospf 1 network 10.255.255.4 0.0.0.0 area 0 network 192.168.100.14 0.0.0.0 area 0 network 192.168.100.22 0.0.0.0 area 0

router bgp 1 neighbor LOCAL peer-group neighbor LOCAL remote-as 1

neighbor LOCAL password 7 15371309360922372D62 neighbor LOCAL update-source LoopbackO neighbor LOCAL next-hop-self neighbor 10.255.255.1 peer-group LOCAL neighbor 10.255.255.2 peer-group LOCAL neighbor 10.255.255.4 peer-group LOCAL neighbor 192.168.100.30 remote-as 4 neighbor 192.168.100.34 remote-as 5

2 AS 2 in Table 3-4 is a stub (nontransit) AS, and its IGP is EIGRP. Configure the routers in AS 2 to speak EBGP to any external peers and to redistribute any EIGRP routes into BGP. Redistribute BGP-learned routes into EIGRP. Implement any necessary filters to prevent incorrect routes from being redistributed.

Answer*

router eigrp 2

redistribute bgp 2 route-map External_Routes metric 10000 100 255 1 1500

passive-interface SerialO

network 192.168.1.0

network 192.168.100.0

no auto-summary router bgp 2 redistribute eigrp 2 route-map Internal__Routes neighbor 192.168.100.1 remote-as 1

îp as-path access-list 1 deny _2_ îp as-path access-list 1 permit îp as-path access-list 2 permit route-map External_Routes permit 10 match as-path 1

route map Internal_Routes permit 10 match as path 2

router eigrp 2

redistribute bgp 2 route map External_Routes metric 10000 100 255 1 1500

passive interface SerialO

network 192 168 1 0

network 192 168 100 0

no auto summary

router bgp 2 redistribute eigrp 2 route map Internal_Routes neighbor 192 168 100 9 remote as 1

i ip as path access list 1 deny _2_

ip as path access list 1 permit ip as path access list 2 permit $

route map External_Routes permit 10 match as path 1

route map Internal_Routes permit 10 match as path 2

3 Networks 192 168 1 0 192 168 2 0 192 168 3 0 192 168 4 0 and 192 168 5 0 exist within AS 2 The administrator of this AS wants the neighboring AS to prefer R5 when sending traffic to 192 168 1 0 and 192 168 3 0 The neighboring AS should prefer R6 when sending traffic to 192 168 2 0 and 192 168 4 0 In each case the less preferred link serves as a backup to the more preferred link 192 168 5 0 is a private network and must not be advertised to any EBGP peer Modify the configurations written in Exercise 2 to implement this policy

Answer: Note that in these configurations the AS_PATH filters from Exercise 2 remain Although not entirely necessary due to the access lists filtering specific prefixes in a real network they can act as an extra bit of insurance against the wrong routes being advertised

router eigrp 2

redistribute bgp 2 route map External_Routes metric 10000 100 255 1 1500

passive interface SerialO

network 192 168 1 0

network 192 168 100 0

no auto summary i router bgp 2 redistribute eigrp 2 route map Internal_Routes neighbor 192 168 100 1 remote as 1

(Continued)

ip as path access list 1 deny _2_ ip as path access list 1 permit ip as path access list 2 permit $ i access list 1 permit 192 168 1 0 access list 1 permit 192 168 3 0 access list 2 permit 192 168 2 0 access list 2 permit 192 168 4 0

route map External_Routes permit 10 match as path 1

route map Internal_Routes permit 10 match ip address 1 match as path 2 set metric 50

route map Internal_Routes permit 20 match ip address 2 match as path 2 set metric 150

router eigrp 2

redistribute bgp 2 route map External_Routes metric 10000 100 255 1 1500

passive interface Serial0

network 192 168 1 0

network 192 168 100 0

no auto summary i router bgp 2 redistribute eigrp 2 route map Internal_Routes neighbor 192 168 100 9 remote as 1

ip as path access list 1 deny _2_ ip as path access list 1 permit ip as path access list 2 permit $ i access list 1 permit 192 168 2 0 access list 1 permit 192 168 4 0 access list 2 permit 192 168 1 0 access list 2 permit 192 168 3 0 i route map External_Routes permit 10 match as path 1

route map Internal_Routes permit 10 match ip address 1 match as path 2 set metric 50

i route map Internal_Routes permit 20

match ip address 2 match as path 2 set metric 150

Configure the EBGP neighbors of R5 and R6 to advertise a default route to AS 2 No other routes are to be advertised

Answer:

router ospf 1 network 10 255 255 10 0 0 0 area 0 network 192 168 100 5 0 0 0 0 area 0 network 192 168 100 13 0 0 0 0 area 0

i router bgp 1 neighbor LOCAL peer group neighbor LOCAL remote as 1

neighbor LOCAL password 7 15371309360922372D62 neighbor LOCAL update source Loopback0 neighbor LOCAL next hop self neighbor 10 255 255 2 peer group LOCAL neighbor 10 255 255 3 peer group LOCAL neighbor 10 255 255 4 peer group LOCAL neighbor 192 168 100 2 remote as 2 neighbor 192 168 100 2 default originate neighbor 192 168 100 2 distribute list 1 out i access list 1 permit 0 0 0 0

access list 1 deny any

router ospf 1 network 10 255 255 2 0 0 0 0 area 0 network 192 168 100 6 0 0 0 0 area 0 network 192 168 100 17 0 0 0 0 area 0

i router bgp 1 neighbor LOCAL peer group neighbor LOCAL remote as 1

neighbor LOCAL password 7 15371309360922372D62 neighbor LOCAL update source Loopback0 neighbor LOCAL next hop self neighbor 10 255 255 1 peer group LOCAL neighbor 10 255 255 3 peer group LOCAL neighbor 10 255 255 4 peer group LOCAL neighbor 192 168 100 10 remote as 2 neighbor 192 168 100 10 default originate neighbor 192 168 100 10 distribute list 1 out neighbor 192 168 100 58 remote as 6

i access list 1 permit 0 0 0 0

access list 1 deny any

5 The administrator of AS 2 s neighboring AS disagrees with part of the policy set in Exercise 2 He wants all routers in his AS to send traffic destined for 192 168 3 0 to R6 with R5 as a backup All traffic destined for 192 168 4 0 should be sent to R5 with R6 as a backup The rest of the policy set in Exercise 2 is acceptable Write configurations to implement this policy

Answer: Remember that LOCAL_PREF is considered ahead of MED in the BGP decision process Therefore changing fhe default LOCAL_PREF attributes of the appropriate routes on the appropriate routers in AS 2 overrides the routes MEDs

router bgp 1 neighbor LOCAL peer group neighbor LOCAL remote as 1

neighbor LOCAL password 7 15371309360922372D62 neighbor LOCAL update source Loopback0 neighbor LOCAL next hop self neighbor 10 255 255 2 peer group LOCAL neighbor 10 255 255 3 peer group LOCAL neighbor 10 255 255 4 peer group LOCAL neighbor 192 168 100 2 remote as 2 neighbor 192 168 100 2 route map SET__PREF in neighbor 192 168 100 2 default originate neighbor 192 168 100 2 distribute list 1 out

access list 1 permit 0 0 0 0 access list 1 deny any access list 2 permit 192 168 4 0 access list 2 deny any i route map SET_PREF permit 10 match ip address 2 set local preference 200

i route map SET_PREF permit 20

router bgp 1 neighbor LOCAL peer group neighbor LOCAL remote as 1

neighbor LOCAL password 7 15371309360922372D62 neighbor LOCAL update source Loopback0 neighbor LOCAL next hop self neighbor 10 255 255 1 peer group LOCAL neighbor 10 255 255 3 peer group LOCAL neighbor 10 255 255 4 peer group LOCAL neighbor 192 168 100 10 remote as 2 neighbor 192 168 100 10 route map SET__PREF in neighbor 192 168 100 10 default originate neighbor 192 168 100 10 distribute list 1 out neighbor 192 168 100 58 remote as 6

i access list 1 permit 0 0 0 0 access list 1 deny any access list 2 permit 192 168 3 0 access list 2 deny any route map SETJPREF permit 10 match ip address 2 set local preference 200

i route map SET__PREF permit 20

6 AS 3 in Table 3 4 is a stub AS and AS 4 is a transit AS The IGP of both autonomous systems is OSPF and the internal interfaces of R7 and R8 are both in area 0 Write BGP and OSPF configurations for R7 and R8 advertise the internal addresses shown in Table 3 5 to all EBGP peers and ensure that routers in the OSPF domains can reach any external destination Do not redistribute routes in either direction Also ensure that the BGP router ID of R7 is 192 168 3 254

Answer: The route map STUB at R7 prevents routes received from an EBGP peer from being advertised to other EBGP peers thus making the AS nontransit R8 has no such route filter, so AS 4 is a transit AS

router ospf 3 network 10 255 255 7 0 0 0 0 area 0 network 172 16 1 1 0000 area 0 default information originate i router bgp 3 bgp router id 192 168 3 254 network 172 16 1 0 mask 255 255 255 0 network 172 16 3 0 mask 255 255 255 0 network 172 17 0 0

network 192 168 6 128 mask 255 255 255 128 neighbor 192 168 100 25 remote as 1 neighbor 192 168 100 25 ebgp multihop 2 neighbor 192 168 100 25 update source Loopback0 neighbor 192 168 100 25 route map STUB out neighbor 192 168 100 38 remote as 4 neighbor 192 168 100 38 route map STUB out neighbor 192 168 100 42 remote as 5 neighbor 192 168 100 42 route map STUB out no auto summary i ip route 00000000 Null0

(Continued)

ip as path access list 1 permit $ i route map STUB permit 10 match as path 1

router ospf 4 network 10 255 255 8 0 0 0 0 area 0 network 172 16 2 1 0 0 0 0 area 0 default information originate

router bgp 4 network 172 16 2 0 mask 255 255 255 0 network 172 16 4 0 mask 255 255 255 0 network 172 18 0 0

network 192 168 6 0 mask 255 255 255 128 neighbor 192 168 100 29 remote as 1 neighbor 192 168 100 37 remote as 3 neighbor 192 168 100 46 remote as 5 no auto summary i ip route 00000000 Null0

Table 3 5 Destinations Internal to AS 3 and AS 4

AS 3

AS 4

172 16 1 0/24

172 16 2 0/24

172 16 3 0/24

172 16 4 0/24

172 17 0 0/16

172 18 0 0/16

192 168 6 128/25 192 168 6 0/25

192 168 6 128/25 192 168 6 0/25

7 Modify the configurations of Exercise 6 so that R7 and R8 speak OSPF across the link directly connecting them remove BGP from the link Traffic between subnets 172 16 3 0/24 and 172 16 4 0/24 should prefer this direct link and should use any EBGP links only as backup Traffic between the other addresses internal to AS 3 and AS 4 should use the EBGP links and should use the direct link only as backup Additionally traffic from other autonomous systems can use the direct link as a backup route If an EBGP link to AS 4 fails for example the neighboring AS can send traffic destined for AS 4 to AS 3 to be forwarded to AS4 across the direct link

Answer:

router ospf 3 network 10 255 255 7 0 0 0 0 area 0 network 172 16 1 1 0 0 0 0 area 0

network 192 168 100 37 0 0 0 0 area 0 default information originate i router bgp 3 bgp router id 192 168 3 254 network 172 16 1 0 mask 255 255 255 0 network 172 16 3 0 mask 255 255 255 0 backdoor network 172 17 0 0

network 192 168 6 128 mask 255 255 255 128 neighbor 192 168 100 25 remote as 1 neighbor 192 168 100 25 ebgp multihop 2 neighbor 192 168 100 25 update source Loopback0 neighbor 192 168 100 25 route map STUB out neighbor 192 168 100 42 remote as 5 neighbor 192 168 100 42 route map STUB out no auto summary

ip route 00000000 Null0

i ip as path access list 1 permit $

i route map STUB permit 10 match as path 1

router ospf 4 network 10 255 255 8 0 0 0 0 area 0 network 172 16 2 1 0 0 0 0 area 0 network 192 168 100 38 0 0 0 0 area 0 default information originate i router bgp 4 network 172 16 2 0 mask 255 255 255 0 network 172 16 4 0 mask 255 255 255 0 backdoor network 172 18 0 0

network 192 168 6 0 mask 255 255 255 128 neighbor 192 168 100 29 remote as 1 neighbor 192 168 100 46 remote as 5 no auto summary i ip route 00000000 Null0

8 AS 5 in Table 3 4 is a transit AS and its IGP is IS IS The Level 2 area 47 0001 spans the entire AS The internal networks are 192 168 9 0 192 168 10 0 192 168 11 0 and 192 168 12 0 Write IS IS and BGP configurations for R9 R10 andRll Ensure that all external routes are known by the routers in the IS IS domain and that all internal networks are advertised to all EBGP peers Do not redistribute IS IS routes into BGP

Answer: These configurations use next hop self although alternatively you could run IS IS in passive mode on the external interfaces

router isis net 47.0001.0000.1234.abed.00 is-type level-2-only redistribute bgp 5 metric 0 metric-type external level-2

router bgp 5 network 192.168.9.0 %

network 192.168.10.0 network 192.168.11.0 network 192.168.12.0 neighbor LOCAL peer-group neighbor LOCAL remote-as 5 neighbor LOCAL update-source LoopbackO neighbor LOCAL next-hop-self neighbor 10.255.255.10 peer-group LOCAL neighbor 10.255.255.11 peer-group LOCAL neighbor 192.168.100.41 remote-as 3

router isis net 47.0001.0000.5678.ef01.00 is-type level-2-only redistribute bgp 5 metric 0 metric-type external level-2

router bgp 5 network 192.168.9.0 network 192.168.10.0 network 192.168.11.0 network 192.168.12.0 neighbor LOCAL peer-group neighbor LOCAL remote-as 5 neighbor LOCAL update-source LoopbackO neighbor LOCAL next-hop-self neighbor 10.255.255.9 peer-group LOCAL neighbor 10.255.255.11 peer-group LOCAL neighbor 192.168.100.45 remote-as 4

router isis net 47.0001.0000.4321.deba.00 is-type level-2-only redistribute bgp 5 metric 0 metric-type external level-2

router bgp 5 network 192.168.9.0 network 192.168.10.0 network 192.168.11.0 network 192.168.12.0 neighbor LOCAL peer-group neighbor LOCAL remote-as 5 neighbor LOCAL update-source LoopbackO

neighbor LOCAL next hop self neighbor 10 255 255 9 peer group LOCAL neighbor 10 255 255 10 peer group LOCAL neighbor 192 168 100 33 remote as 1

9 Modify the configurations written in Exercise 8 so that network 192 168 12 0 is known only by AS 4 and no other autonomous system

Answer: The network statement for 192 168 12 0 is removed from the configurations of R9 and Rll so that they do not advertise that network At RIO the NO_EXPORT community is added to the route to 192 168 12 0 so that it is not advertised beyond AS 4

router isis net 47 0001 0000 1234 abed 00 is type level 2 only redistribute bgp 5 metric 0 metric type external level 2

i router bgp 5 network 192 168 9 0 network 192 168 10 0 network 192 168 11 0 neighbor LOCAL peer group neighbor LOCAL remote as 5 neighbor LOCAL update source LoopbackO neighbor LOCAL next hop self neighbor 10 255 255 10 peer group LOCAL neighbor 10 255 255 11 peer group LOCAL neighbor 192 168 100 41 remote as 3

router isis net 47 0001 0000 5678 ef01 00 is type level 2 only redistribute bgp 5 metric 0 metric type external level 2

router bgp 5 network 192 168 9 0 network 192 168 10 0 network 192 168 11 0 network 192 168 12 0 neighbor LOCAL peer group neighbor LOCAL remote as 5 neighbor LOCAL update source LoopbackO neighbor LOCAL next hop self neighbor 10 255 255 9 peer group LOCAL neighbor 10 255 255 11 peer group LOCAL neighbor 192 168 100 45 remote as 4

(Continued) neighbor 192.168.100.45 send-community neighbor 192.168.100.45 route-map EXPORT_COMMUNITY out access-list 1 permit 192.168.12.0

route-map EXPORT_COMMUNITY permit 10 match lp address 1

set community no-export *

route-map EXPORT_COMMUNITY permit 20

Rll router isis net 47.0001.0000.4321.dcba.00 ls-type level-2-only redistribute bgp 5 metric 0 metric-type external level-2

router bgp 5 network 192.168.9.0 network 192.168.10.0 network 192.168.11.0 neighbor LOCAL peer-group neighbor LOCAL remote-as 5 neighbor LOCAL update-source LoopbackO neighbor LOCAL next-hop-self neighbor 10.255.255.9 peer-group LOCAL neighbor 10.255.255.10 peer-group LOCAL neighbor 192.168.100.33 remote-as 1

10 Modify the configurations written in Exercise 9 so that AS 3 and AS 4 prefer the path through AS 1 to reach network 192.168.11.0.

Answer* Network 192.168.11.0 is advertised normally by Rll but is prepended by R9 and RIO.

router isis net 47.0001.0000.1234.abed.00 ls-type level-2-only redistribute bgp 5 metric 0 metric type external level-2

router bgp 5 network 192.168.9.0 network 192.168.10.0 network 192.168.11.0 neighbor LOCAL peer-group neighbor LOCAL remote-as 5 neighbor LOCAL update-source Loopback0 neighbor LOCAL next-hop-self neighbor 10.255.255.10 peer-group LOCAL

neighbor 10 255 255 11 peer group LOCAL neighbor 192 168 100 41 remote as 3 neighbor 192 168 100 41 route map PREPEND out i access list 1 permit 192 168 11 0

route map PREPEND permit 10 match ip address 1 set as path prepend 5 5

i route map PATH permit 20

router isis net 47 0001 0000 5678 ef01 00 is type level 2 only redistribute bgp 5 metric 0 metric type external level 2

i router bgp 5 network 192 168 9 0 network 192 168 10 0 network 192 168 11 0 network 192 168 12 0 neighbor LOCAL peer group neighbor LOCAL remote as 5 neighbor LOCAL update source LoopbackO neighbor LOCAL next hop self neighbor 10 255 255 9 peer group LOCAL neighbor 10 255 255 11 peer group LOCAL neighbor 192 168 100 45 remote as 4 neighbor 192 168 100 45 send community neighbor 192 168 100 45 route map EXPORT_COMMUNITY out

access list 1 permit 192 168 12 0

access list 2 permit 192 168 11 0

route map EXPORT.COMMUNITY permit 10 match ip address 1 set community no export i route map EXPORT_COMMUNITY permit 20 match ip address 1 set as path prepend 5 5

i route map EXPORT_COMMUNITY permit 30

Rll router isis net 47 0001 0000 4321 dcba 00 is type level 2 only redistribute bgp 5 metric 0 metric type external level 2

(Continued) router bgp 5 network 192 168 9 0 network 192 168 10 0 network 192 168 11 0 neighbor LOCAL peer group neighbor LOCAL remote as 5 neighbor LOCAL update source Loopback0 neighbor LOCAL next hop self neighbor 10 255 255 9 peer group LOCAL neighbor 10 255 255 10 peer group LOCAL neighbor 192 168 100 33 remote as 1

11 The networks internal to AS 6 in Table 3 4 are 192 168 16 0 192 168 17 0

192 168 18 0 and 192 168 19 0 Write a BGP configuration for R12 that advertises these networks to the neighboring AS and that also advertises a summary route for the networks The neighboring AS should advertise only the summary to other autonomous systems

Answer:

router bgp 6 network 192 168 16 0 network 192 168 17 0 network 192 168 18 0 network 192 168 19 0

aggregate address 192 168 16 0 255 255 252 0 neighbor 192 168 100 57 remote as 1 neighbor 192 168 100 57 send community neighbor 192 168 100 57 route map AGGREGATE out

access list 101 permit ip host 192 168 16 0 host 255 255 252 0

route map AGGREGATE permit 10 match ip address 101 set community none

route map AGGREGATE permit 20 set community no export

12 Modify the most recent configuration you wrote for R12 s EBGP neighbor so that the neighbor does not accept prefixes that do not belong to the aggregate being advertised by R12 does not accept prefixes longer than 24 bits and does not accept more than five prefixes

Answer:

router bgp 1 neighbor LOGAL peer-group neighbor LOCAL remote-as 1

neighbor LOCAL password 7 [email protected]@922372D62 neighbor LOCAL update-source Loopback® neighbor LOCAL next-hop-self neighbor 1©.255.255=1 peer-group LOCAL neighbor 18=255.255.3 peer-group LOCAL neighbor 10,255.255.4 peer-group LOCAL neighbor 192.168.100.10 remote-as 2 neighbor 192.168.100.10 route-map SETJPREF in neighbor 192.168.100.10 default-originate neighbor 192.168.100.10 distribute-list 1 out neighbor 192.168.100.58 remote-as 6 neighbor 192.168.100,58 maximum-prefix 5 neighbor 192.168.100.58 route-map PREFIXJ.IWIT in

access-list 1 deny any access-list 2 permit 192.168.3.0

access-list 2 deny any

ip prefix-list ASS seq 5 permit 192.168.16.0/22 le 24

route-map SETJPREF permit 1® match ip address 2 set local-preference 20©

route-map SETJPREF permit 20

route-map PREFIXJLIMIT permit 10 match ip address prefix-list ASS

13 Example 3-164 shows a BGP configuration for R7 in Table 3-4. The internal prefixes shown in Table 3-5 are advertised by OSPF.

Example 3-184 BGP Configuration of Router R7

router bgp 3 redistribute ospf 1 neighbor NEIGHBORS peer-group neighbor NEIGHBORS ebgp-multihop 2 neighbor NEIGHBORS update-source Loopback© neighbor NEIGHBORS route-map EX13 out neighbor 10.255.255.8 remote-as 4 neighbor 10.255.255.8 peer-group NEIGHBORS neighbor 10.255.255.9 remote-as 5

Example 3 164 BGP Configuration of Router R7 (Continued)

neighbor 10 255 255 9 peer group NEIGHBORS neighbor 10 255 255 3 remote as 1 neighbor 10 255 255 3 peer group NEIGHBORS no auto summary

ip classless ip as path access list 1 permit 12$ ^

access list 1 permit 172 16 1 0

access list 2 permit 172 16 3 0

i route map EX13 permit 10 match ip address 1 set as path prepend 2

route map EX13 permit 20 match ip address 2 set as path prepend 1

i route map EX13 permit 30 match as path 1 set as path prepend 4 5

i route map EX13 deny 40

Explain the effects of route map EX 13

Answer: Term 10 of the route map matches prefix 172 16 1 0 and prepends 2 to the AS_PATH As a result routers in AS 2 will reject the prefix Term 20 matches prefix 172 16 2 0 and prepends 1 to the AS_PATH so the route is rejected by routers in AS 1 Term 30 matches routes that have an AS_PATH of [1 2] meaning routes that are originated in AS 2 and have been advertised by AS 1 That term prepends 4 and 5 to the AS_PATH of these routes so they are rejected by AS 4 and AS 5 Term 40 suppresses the advertisement of any other routes

14 Router R1 in Figure 3 36 is a route reflector for routers R2 R3 and R4 and is connected to those neighbors via Frame Relay PVCs Write a BGP configuration for R1 that provides full connectivity for the networks attached to the four routers The cluster ID is 6500

Figure 3 36 The Route Reflection Cluster for Configuration Exercise 14

Figure 3 36 The Route Reflection Cluster for Configuration Exercise 14

router bgp 6500 no synchronization bgp cluster id 6500 network 172 20 0 0 neighbor 172 16 1 1 remote as 6500 neighbor 172 16 1 1 route reflector client neighbor 172 16 1 2 remote as 6500 neighbor 172 16 1 2 route reflector client neighbor 172 16 1 3 remote as 6500 neighbor 172 16 1 3 route reflector client

Was this article helpful?

0 0
100 SEO Tips

100 SEO Tips

100 SEO Tips EVERY SEO Enthusiast Should Know. This Report 100 SEO Tips will help you to Utilize These Tips to Dominate The Search Engine Today.

Get My Free Ebook


Post a comment