OSPF Routes Missing from Routing Table

Symptom: OSPF routes and networks are not being advertised to other routers. Routers in one area are not receiving routing information for other areas. Some hosts cannot communicate with hosts in other areas, and routing table information is incomplete.

Table 7-12 outlines the problems that might cause this symptom and describes solutions to those problems.

Table 7-12 OSPF: Routes Missing from Routing Table

Possible Problem

Solution

OSPF routers not establishing neighbors

Follow the procedures outlined in the section "OSPF: Routers Not Establishing Neighbors" earlier in this chapter.

Routing information from IGRP or RIP is not redistributed correctly into OSPF

No ABR is configured in an area, isolating that area from the OSPF backbone

Step 1 Check the router configuration using the show running-config privileged exec command.

Step 2 Look for a redistribute router configuration command entry. Make sure that redistribution is configured and that the subnets keyword is used with the command.

The subnets keyword must be included when IGRP or RIP is redistributed into OSPF; otherwise, only major routes (not subnet routes) are redistributed.

Step 3 If the redistribute command is not present, or if the subnets keyword is not specified, add or change the configuration using the following commands:

C7000(config)#router ospf 100 C7000(config)#redistribute ospf subnets

Step 1 Use the show running-config privileged exec command on OSPF routers to verify that at least one ABR exists for the area. ABRs must belong to area 0, the OSPF backbone, as well as to another area. Look for network statements which indicate that the router is part of area 0.

To define the interfaces on which OSPF runs and to define the area ID for those interfaces, use the network area router configuration command:

network address wildcard-mask area area-id

Syntax Description:

• wildcard-mask—IP-address-type mask that includes "don't care" bits.

• area-id—Area that is to be associated with the OSPF address range. It can be specified as either a decimal value or as an IP address. If you intend to associate areas with IP subnets, you can specify a subnet address as the area-id.

Step 2 If no ABR exists in an area, configure one where appropriate. Use the network router configuration command.

For example, to configure OSPF process 100 to participate in the OSPF backbone area, enter the following commands:

C4500(config)#router ospf 100

C4500(config-router)#network 192.21.3.7 0.0.0.255 area 0

Possible Problem Solution

Interface network type In an OSPF Frame Relay environment, if one end of the link is a multipoint mismatch on Frame interface and the other end is a point-to-point interface, by default the multipoint

Relay WAN interface will advertise the link as a non-broadcast network and the point-to-point interface will advertise the link as a point-to-point network. This creates a conflict in the link-state database and can prevent routing information from being learned properly.

Step 1 Check each router interface on each side of the link to see whether the network types are mismatched. Use the show ip ospf interface privileged exec command to check the network type configured for the interface.

Following is an example of the output from the show ip ospf interface command:

Ethernet0 is up, line protocol is up

Internet Address 192.168.52.14 255.255.255.0, Area 0 Process ID 1, Router ID 192.168.52.14,

In this example, the network type is broadcast.

Step 2 Change the point-to-point interface to a multipoint interface by configuring subinterfaces, or change the network type of the point-to-point interface to broadcast using the ip ospf network broadcast interface configuration command.

The following example sets your OSPF network as a broadcast network:

interface serial 0 ip address 160.89.77.17 255.255.255.0 ip ospf network broadcast encapsulation frame-relay For information on configuring subinterfaces, see the Cisco IOS configuration guides.

Route redistribution is not possible in OSPF stub areas. No external routes are advertised into a stub area, and if the area area-id stub no-summary router configuration command is used, no summary routes (inter-area routes) will be advertised into the stub area.

Step 1 If you want summary routes to be advertised into the stub area, but you do not see them in the routing table, use the show running-config privileged exec command to view the router configuration.

Step 2 Look for an area area-id stub no-summary command entry. If this command is present, disable it by entering the following commands:

C4500(config)#router ospf 100

C4500(config-router)#no area 1 stub no-summary This disables the no-summary keyword and keeps the router configured as a stub.

Step 3 To advertise external routes into the area, you must configure the area as a non-stub. Make certain that all routers in the area are reconfigured as non-stub routers.

Area is configured as a stub area

Possible Problem

Solution

Misconfigured route filtering

Misconfigured route filtering

Step 1 Use the show running-config command to check suspect routers.

Step 2 See if there are any distribute-list in or distribute-list out router configuration commands configured on the router.

The distribute-list in command prevents specific information learned in LSAs1 from being included in the OSPF routing table. The distribute-list out command prevents a router from including specific information in routing updates that it transmits. However, in OSPF, distribute-list out can be configured only on an ASBR2 to filter external routes.

Note: Although distribute-list commands prevent specific information from being included in the OSPF routing table, information about those networks is contained in the link-state database and is flooded through the network in LSAs. This means that downstream routers will include that information in their routing tables unless they, too, filter those routes from the routing table.

Step 3 If distribute-list commands are configured on the router, disable them using the no version of the command.

For example, to disable an incoming filter that references access list 10, enter the following command:

C7500(config)#no distribute-list 10 in

Step 4 After disabling all distribution lists, use the clear ip route privileged exec command to clear the routing table.

Step 5 Determine whether the routes appear in the routing table by using the show ip route privileged exec command. If routes appear properly in the routing table, the access list referenced by the distribute-list command is probably configured to deny certain updates.

Step 6 To isolate the problem list, enable distribution lists one at a time until the routes no longer appear in the table.

Step 7 Use the show running-config command and check the access list to make sure it does not deny updates inappropriately. If the access list denies updates from specific addresses, make sure that it does not deny the address of a router from which routing updates should be received. Change the access list to allow the router to receive updates from the proper addresses. At the end of every access list is an implied "deny all traffic" criteria statement. Therefore, if a packet does not match any of your criteria statements, the packet is blocked. Configure explicit permit statements for those addresses from which the router should receive updates.

Step 8 If you altered an access list, enable the distribution list using the distribute-list command. Use the clear ip route command and check whether the missing routing information appears in the routing table.

Step 9 If the routes appear in the routing table, perform the preceding steps on every router in the path until all distribution lists are enabled and routing information appears properly in the routing table.

For more information on configuring access lists, see the Cisco IOS configuration guides.

IP Enhanced IGRP: Routers Not Establishing Neighbors

Possible Problem

Solution

Virtual link is misconfigured

Step 1 Check the configuration of the routers at each end of the virtual link using the show running-config privileged exec command.

Look for area area-id virtual-link router-id router configuration command entries. These commands are used to configure the virtual link.

Step 2 Use the show ip ospf exec command to find the router ID (IP address) of the routers.

Step 3 Add the area area-id virtual-link router-id command if it is missing, or modify it if it is incorrect. Make sure that the proper area ID and router ID (IP address) are specified. The routers at each end of the virtual link must point to one another across the transit area.

For example, in the network shown in Figure 7-13, a virtual link from Router B to Router A is created across the transit area, Area 1.

The following commands are entered on Router A:

C4500(config)#router ospf 250

C4500(config-router)#network 121.10.0.0 0.0.255.255 area 0

C4500(config-router)#network 169.192.56.0 0.0.0.255 area 0

C4500(config-router)#area 1 virtual-link 121.10.100.46 On Router B, the following commands are used:

C4000(config)#router ospf 250

C4000(config-router)#network 121.10.0.0 0.0.255.255 area 0

C4000(config-router)#network 108.31.0.0 0.0.255.255 area 2

C4000(config-router)#area 1 virtual-link 121.10.1.1

1 LSA = link state advertisement

2 ASBR = autonomous system border router

Figure 7-13 An OSPF Virtual Link Example

Interface E0 Interface E0 121.10.1.1 121.10.100.46

Figure 7-13 An OSPF Virtual Link Example

Interface E0 Interface E0 121.10.1.1 121.10.100.46

Interface E1 169.192.56.10

Interface E1 108.31.1.1

Interface E1 169.192.56.10

Interface E1 108.31.1.1

Was this article helpful?

0 -2
The Ultimate Computer Repair Guide

The Ultimate Computer Repair Guide

Read how to maintain and repair any desktop and laptop computer. This Ebook has articles with photos and videos that show detailed step by step pc repair and maintenance procedures. There are many links to online videos that explain how you can build, maintain, speed up, clean, and repair your computer yourself. Put the money that you were going to pay the PC Tech in your own pocket.

Get My Free Ebook


Responses

  • CIRIACO
    Why ospf route not in routing table?
    8 months ago

Post a comment