To a Common Network

Default hello interval = 10 seconds

Router A

interface Loop bac kO

ip address 1.1.1.1 255.255.255.255

interface SerialO/1

ip address 10.1.1.1 255.255.255.252

clockrate 64000

router ospf 1

network 10.1.1.0 0.0.0.3 area 0 network 1.1.1.1 0.0.0.0 area 1

Router B

interface Loop bac kO

ip address 2.2.2.2 255.255.255.255

interface SerialO

ip address 10.1.1.2 255.255.255.252 router ospf 1

network 10.1.1.0 0.0.0.3 area 0 network 2.2.2.2 0.0.0.0 area 2

View the timer values for the serial interface on Routers A and B.

rtrA#show ip ospf interface sO/1

SerialO/1 is up, line protocol is up Internet Address 10.1.1.1/30, Area 0

Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 1562 Transmit Delay is 1 sec, State POINT_TO_POINT,

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 Hello due in 00:00:09 Index 1/2, flood queue length 0 Next 0x0(0)/0x0(0)

Last flood scan length is 1, maximum is 2 Last flood scan time is 0 msec, maximum is 4 msec Neighbor Count is 1, Adjacent neighbor count is 1 Adjacent with neighbor 2.2.2.2 Suppress hello for 0 neighbor(s)

rtrB#show ip ospf interface serial 0

SerialO is up, line protocol is up Internet Address 10.1.1.2/30, Area 0

Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64 Transmit Delay is 1 sec, State POINT_TO_POINT,

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 Hello due in 00:00:09 Neighbor Count is 1, Adjacent neighbor count is 1 Adjacent with neighbor 1.1.1.1 Suppress hello for 0 neighbor(s)

Notice that the default Hello interval is 10 seconds and the default dead interval is 40 seconds. Modify the configuration on Router A to change the Hello interval to 11 seconds while leaving the value for the Hello interval on Router B set to the default of 10 seconds.

interface SerialO/1 bandwidth 64

ip address 10.1.1.1 255.255.255.252

ip ospf hello-interval 11

clockrate 64000

Inspect the OSPF interface timers for serial 0/1 on Router A.

rtrA#show ip ospf interface serial 0/1

Serial0/1 is up, line protocol is up Internet Address 10.1.1.1/30, Area 0

Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 1562 Transmit Delay is 1 sec, State POINT_TO_POINT,

Timer intervals configured, Hello 11, Dead 44, Wait 44, Retransmit 5 Hello due in 00:00:05 Index 1/2, flood gueue length 0 Next 0x0(0)/0x0(0)

Last flood scan length is 0, maximum is 2 Last flood scan time is 0 msec, maximum is 4 msec Neighbor Count is 0, Adjacent neighbor count is 0 Suppress hello for 0 neighbor(s)

The dead timer has been automatically set to four times the Hello interval. Verify that Routers A and B have an OSPF neighbor relationship.

rtrA#show ip ospf neighbor

(no output)

Because the Hello interval time on Router A does not match the Hello interval on Router B, an OSPF neighbor relationship will notbe established. This can be seen by enabling OSPF debugging on Router B.

rtrB#debug ip ospf adj

OSPF adjacency events debugging is on rtrB#

17:03:20: OSPF: Rev hello from 1.1.1.1 area 0 from SerialO 10.1.1.1 17:03:20: OSPF: Mismatched hello parameters from 10.1.1.1 17:03:20: Dead R 44 C 40, Hello R 11 C10

Modify the Hello interval on Router B to match the Hello interval on Router A. Router B

interface SerialO

ip address 10.1.1.2 255.255.255.252

ip ospf hello-interval 11

Was this article helpful?

0 0

Post a comment