Figure 23 External OSPF Routes Are Not Advertised into an OSPF Stub Area Interarea and External Routes Are Not Advertised into a Totally Stubby Area

Router A

interface Loop bac kO

ip address 1.1.1.1 255.255.255.255

interface Se rial 0/1

ip address 10.1.1.1 255.255.255.252

clock rate 64000

router ospf 1

Router B

interface Loop bac kO

ip address 2.2.2.2 255.255.255.255

interface SerialO

ip address 10.1.1.2 255.255.255.252

interface SeriaH

ip address 10.1.1.5 255.255.255.252 clock rate 64000

router ospf 1

network 10.1.1.0 0.0.0.3 area 1 network 10.1.1.4 0.0.0.3 area 0

Router C

interface Loop bac kO

ip address 3.3.3.3 255.255.255.255

interface SerialO

ip address 10.1.1.6 255.255.255.252 router ospf 1

redistribute connected subnnets network 10.1.1.4 0.0.0.3 area 0

If you examine the IP routing table on Router A, you can see that all OSPF routes are being advertised into Area 1. rtrA#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default U - per-user static route, o - ODR

Gateway of last resort is not set

1.0.0.0/32 issubnetted, 1 subnets C 1.1.1.1 is directly connected, LoopbackO

3.0.0.0/32 is subnetted, 1 subnets

O E2 3.3.3.3 [110/20] via 10.1.1.2, 00:00:04, SerialO/1

10.0.0.0/30 is subnetted, 3 subnets C 10.1.1.0 is directly connected, SerialO/1

O IA 10.1.1.4 [110/128] via 10.1.1.2, 00:00:04, SerialO/1

Modify the configurations on Routers A and B so that Area 1 is a stub area.

Was this article helpful?

0 0

Post a comment