Configuration Example Unconditionally Advertising a Default Route into the OSPF Domain

Configure the routers in Figure 4-2 as shown in the following code.

Figure 4-2. When OSPF Advertises a Default Route, the Advertising Router Becomes an ASBR. The default-information-originate always Command Will Unconditionally Advertise a Default Route

Figure 4-2. When OSPF Advertises a Default Route, the Advertising Router Becomes an ASBR. The default-information-originate always Command Will Unconditionally Advertise a Default Route

Router A

interface Loop bac kO

interface EthernetO/O

ip address 172.16.1.1 255.255.255.0

router ospf 1

network 1.1.1.1 0.0.0.0 area 0 network 172.16.1.0 0.0.0.255 area 0

Router B

interface Loop bac kO

ip address 2.2.2.2 255.255.255.255

interface EthernetO

ip address 172.16.1.2 255.255.255.0

interface SeriaH bandwidth 64

ip address 10.1.1.5 255.255.255.252 clockrate 64000

router ospf 1

network 2.2.2.2 0.0.0.0 area 0 network 172.16.1.0 0.0.0.255 area 0

Verify that Routers A and B have established an OSPF neighbor relationship, as shown here. rtrA#show ip ospf neighbor

This document was created by an unregistered ChmMagic, please go to http://www.bisenter.com to register it. Thanks Neighbor ID Pri State Dead Time Address Interface 2.2.2.2 1 FULL/BDR 00:00:30 172.16.1.2 Ethernet0/0

rtrB#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface 1.1.1.1 1 FULL/DR 00:00:38 172.16.1.1 EthernetO

Modify the configuration on Router B so that OSPF will unconditionally advertise a default route into the OSPF domain.

Router B router ospf 1

network 2.2.2.2 0.0.0.0 area 0 network 172.16.1.0 0.0.0.255 area 0 default-information originate always

Verification

Verify that the default route is in the IP routing table on Router B.

rtrB#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default U - per-user static route, o - ODR

1.0.0.0/32 issubnetted, 1 subnets O 1.1.1.1 [110/11] via 172.16.1.1, 16:23:59, EthernetO

2.0.0.0/32 issubnetted, 1 subnets C 2.2.2.2 is directly connected, LoopbackO

172.16.0.0/24 is subnetted, 1 subnets C 172.16.1.0 is directly connected, EthernetO

10.0.0.0/30 issubnetted, 1 subnets C 10.1.1.4 is directly connected, SeriaM

Router B does not have a default route in the IP routing table. Verify that a default route is being advertised to Router A. rtrA#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default U - per-user static route, o - ODR

Gateway of last resort is 172.16.1.2 to network 0.0.0.0

1.0.0.0/32 issubnetted, 1 subnets C 1.1.1.1 is directly connected, LoopbackO

2.0.0.0/32 issubnetted, 1 subnets O 2.2.2.2 [110/11] via 172.16.1.2, 00:10:27, Ethernet0/0

172.16.0.0/24 is subnetted, 1 subnets C 172.16.1.0 is directly connected, Ethernet0/0 0*E2 0.0.0.0/0 [110/1 ] via 172.16.1.2, 00:01:17, Ethernet0/0

Troubleshooting

If there is an OSPF relationship between the OSPF routers, then this command should work as expected.

4 PREVIOUS

< Free Open Study >

NEXT ►

* PREVIOUS

< Free Open Study >

Was this article helpful?

0 0

Post a comment