Configuration Example 4 Null Authentication

Prior to Cisco IOS Software Release 12.0, if authentication was configured for an OSPF area then the same authentication type had to be enabled on all interfaces in the area. In Cisco IOS Software Release 12.0 and later, if authentication is not reguired on an interface, NULL authentication can be employed to override the authentication that has been con-figured for the area. Configure the routers in Figure 19-1 with simple password authentication in Area 0 and on the Ethernet network. Do not configure authentication on the serial link.

Router A

interface LoopbackO

ip address 1.1.1.1 255.255.255.255

interface EthernetO/O

ip address 172.16.1.1 255.255.255.0

ip ospf authentication-key laura interface SerialO/1 ip address 10.1.1.1 255.255.255.252 ip ospf authentication null clockrate 64000

router ospf 1

area 0 authentication network 1.1.1.1 0.0.0.0 area 1

network 172.16.1.0 0.0.0.255 area 0

Router B

interface Loop bac kO

ip address 2.2.2.2 255.255.255.255

interface EthernetO

ip add 172.16.1.2 255.255.255.0

ip ospf authentication-key laura interface SerialO

ip address 10.1.1.2 255.255.255.252 ip ospf authentication null router ospf 1

area 0 authentication network 2.2.2.2 0.0.0.0 area 2

Was this article helpful?

0 0

Post a comment