Configuration Example 2 Configuring OSPF Neighbors on a Hub and Spoke Topology with the Neighbors on the Same IP Subnet

In Figure 11-3, Routers A, B, and C areconfigured forahuband spoke topology on a common IP subnet. For this topology, Router A?i/sf be elected as the DR because Router A has a direct connection to Router B and Router C. Routers B or C should never be elected as the DR. To prevent Routers B and C from becoming the DR on the Frame Relay subnet, set the OSPF priority to 0 on both of their interfaces. Configure Routers A, B, and C as shown in the listing that follows.

Figure 11-3. In a Hub and Spoke Topology, the Hub Router Must Be Elected the OSPF DR if the

Spokes Are on the Same IP Subnet

Figure 11-3. In a Hub and Spoke Topology, the Hub Router Must Be Elected the OSPF DR if the

Spokes Are on the Same IP Subnet

Router A

ip address 1.1.1.1 255.255.255.255

interface SerialO/O ip address 10.1.1.1 255.255.255.248 encapsulation frame-relay frame-relay map ip 10.1.1.2 101 broadcast frame-relay map ip 10.1.1.3 102 broadcast no frame-relay inverse-arp frame-relay Imi-type ansi

router ospf 1

network 1.1.1.1 0.0.0.0 area 1 network 10.1.1.0 0.0.0.7 area 0 neighbor 10.1.1.3 neighbor 10.1.1.2

Router B

interface Loop bac kO

ip address 2.2.2.2 255.255.255.255

interface SerialO

ip address 10.1.1.2 255.255.255.248 encapsulation frame-relay ip ospf priority 0

frame-relay map ip 10.1.1.1 110 broadcast frame-relay map ip 10.1.1.3 110 broadcast no frame-relay inverse-arp frame-relay Imi-type ansi router ospf 1

network 2.2.2.2 0.0.0.0 area 2 network 10.1.1.0 0.0.0.7 area 0

Router C

interface LoopbackO

ip address 3.3.3.3 255.255.255.255

interface SerialO

ip address 10.1.1.3 255.255.255.248 encapsulation frame-relay ip ospf priority 0

frame-relay map ip 10.1.1.1 120 broadcast frame-relay map ip 10.1.1.2 120 broadcast no frame-relay inverse-arp frame-relay Imi-type ansi router ospf 1

network 3.3.3.3 0.0.0.0 area 0 network 10.1.1.0 0.0.0.7 area 0

On Routers B and C, there are twoframe-relay map statements. These are needed because Router B receives routes from Router C with a next hop of 10.1.1.3 and Router C receives routes from Router B with a next hop of 10.1.1.2. Because Routers B and C are not directly connected, the frame-relay map statements are required to direct traffic between Routers B and C to go through Router A.

Was this article helpful?

0 0

Post a comment