OSPF Router Considerations

The process for activating OSPF on any type of router begins with the network command. However, a variety of OSPF router types exist that have some unique configuration considerations. The sections that follow discuss these considerations. Before starting the OSPF routing process, consider a few general items about how OSPF is going to be configured to operate in your network. These considerations are as follows:

1 Decide what OSPF routing process ID number you want to assign within your network. One method is to use the AS number that you have been given (if you do not have one, pick a number that is easy to type quickly).

2 Decide if you want OSPF to determine which router becomes the DR and BDR or whether you should use the priority command and make that determination. A router should not be a DR for more than one network.

3 Are you going to use a loopback interface?

4 Turn on the OSPF routing process with the router ospf process-id command, as described in the previous section.

5 Assign the appropriate network statements to the OSPF routing process with the correct area ID, for example:

router ospf 109

network 130.10.8.0 0.0.0.255 area 0 network 172.25.64.0 0.0.0.255 area 1

ABR Considerations

Configuring an ABR for OSPF is essentially the same as described in the preceding section with a few minor considerations that reflect the role this type of OSPF router plays within a network. These considerations are as follows:

1 Is one of the areas that the ABR will connect to a stub area? If so, execute the area area-id stub command, which defines an OSPF area as stub area.

2 You might need to enter the area area-id default-cost command, which assigns a specific cost. You review this command and its effects later in this chapter.

3 Add the area range command so that the networks within each area can be properly summarized, for example:

router ospf 109

network 130.10.8.0 0.0.0.255 area 0

router ospf 109

network 130.10.8.0 0.0.0.255 area 0

274 Chapter 5: Routing Concepts and Configuration network 172.25.64.0 0.0.0.255 area 1 area 1 range 130.10.8.0 255.255.255.0

4 Determine if you are going to use optional OSPF parameters. You do not need to decide now to use any of these options, but be aware that they can help your OSPF network. Although many of these options have not yet been discussed, the following list highlights the more significant optional parameters in command syntax:

area area-id authentication area area-id authentication message-digest ip ospf authentication-key ip ospf hello-interval ip ospf dead-interval timers spf spf-delay spf-holdtime

You can use the show ip ospf border-routers command to see the ABRs within your network. This command is explained in more detail in Chapter 8, "Managing and Securing OSPF Networks."

ASBR Considerations

The process of configuring an Autonomous System Boundary Router (ASBR) for OSPF is similar to how you would configure an ABR. Use the following steps:

Step 1 You should already know what the OSPF process ID is, whether you need a loopback interface, and which optional OSPF parameters you are going to be using.

Step 2 Turn on the OSPF routing process, as previously described in the

"Activating OSPF." Again, use the router ospf process-id command.

Step 3 Assign the appropriate network statements to the OSPF routing process with the correct area ID, for example:

router ospf 109 network 130.10.8.0 0.0.0.255 area 0 network 172.25.64.0 0.0.0.255 area 1

Step 4 Add the area range command so that the networks within each area can be properly summarized. This only works if the ASBR is also an ABR. The use of summary-address statements would be appropriate here, as they are placed on ASBRs, for example:

router ospf 109 network 130.10.2.0 0.0.0.255 area 0 network 130.10.3.0 0.0.0.255 area 0 network 130.10.4.0 0.0.0.255 area 0 network 172.25.64.0 0.0.0.255 area 1

area 1 range 130.10.1.0 255.255.252.0

area 1 range 130.10.1.0 255.255.252.0

The area range command is covered later in this chapter, but notice that the network mask is normal as opposed to being an inverse mask. (Inverse masks are more commonly used in OSPF.)

Step 5 Configure the redistribution process between your OSPF AS and the external AS to which the ASBR is providing connectivity, for example:

router ospf 109

redistribute rip subnets metric-type 1 metric 12

network 130.10.8.0 0.0.0.255 area 0

network 172.25.64.0 0.0.0.255 area 1

area 1 range 130.10.8.0 255.255.255.0

router rip network 128.130.0.0

passive interface s 0

default-metric 5

You can use the show ip ospf border-routers command to see the area border routers within your network. This command is explained in more detail in Chapter 8.

Backbone Router Considerations

The process of configuring an OSPF backbone router for OSPF is similar to how you would configure an ABR. Use the following steps:

Step 1 You should already know what the OSPF process ID, whether you need a loopback interface, and which optional OSPF parameters you are going to use.

Step 2 Turn on the OSPF routing process, as previously described in "Activating OSPF." Again, you use the router ospf process-id command.

Step 3 Assign the appropriate network statements to the OSPF routing process with the correct area ID, for example:

router ospf 109

network 130.10.8.0 0.0.0.255 area 0 network 172.25.64.0 0.0.0.255 area 0

5 Add the area range command if the backbone router is also acting as an ABR so that the networks within each area can be properly summarized, for example:

router ospf 109 network 130.10.2.0 0.0.0.255 area 0 network 130.10.3.0 0.0.0.255 area 0 network 130.10.4.0 0.0.0.255 area 0 network 172.25.64.0 0.0.0.255 area 0

area 1 range 130.10.1.0 255.255.252.0

area 1 range 130.10.1.0 255.255.252.0

276 Chapter 5: Routing Concepts and Configuration

Was this article helpful?

0 0

Post a comment