Example 4 Remote Site Router Is in Two Routing Domains

This approach relies on one-way redistribution of multiple instances of a separate routing protocol into OSPF, as shown in Figure 5-26. Auto-summarization must also be disabled in this scenario. Administrative distances should be tweaked to ensure that OSPF is the favored routing protocol. This approach has the advantage that interfaces can be shared among areas, that is, a dedicated set of interfaces for each area is not required.

Figure 5-26 Remote Site Router in Two Routing Domains

Figure 5-26 Remote Site Router in Two Routing Domains

Example 5-40 shows some sample configurations for this scenario.

Example 5-40 Configuring OSPF for On-Demand Circuits: Remote Site Router Is in Two Routing Domains

! Router A Configuration interface ethernet 0

ip address 132.132.132.193 255.255.255.224 interface serial 0

ip address 132.132.132.254 255.255.255.252 backup interface serial 1 backup delay 0 5 interface serial 1

ip address 132.132.132.250 255.255.255.252 router ospf 1

continues continues

328 Chapter 5: Routing Concepts and Configuration

Example 5-40 Configuring OSPF for On-Demand Circuits: Remote Site Router Is in Two Routing Domains (Continued)

network 132.132.132.192 0.0.0.31 area 1 network 132.132.132.252 0.0.0.3 area 1 router eigrp 1

network 132.132.0.0 distance 200 0.0.0.0 255.255.255.255_

! Router B Configuration interface fddi 0

ip address 132.132.1.1 255.255.255.248 interface serial 0

ip address 132.132.132.253 255.255.255.252 router ospf 1

network 132.132.132.0 0.0.3.255 area 1 area 1 range 132.132.132.0 255.255.252.0 network 132.132.0.0 0.0.255.255 area 0

! Router C Configuration interface fddi 0

ip address 132.132.1.2 255.255.255.248 interface serial 0

ip address 132.132.132.249 255.255.255.252 router ospf 1

network 132.132.1.0 0.0.0.7 area 0

redistribute eigrp 1 subnets metric 32000

router eigrp 1

network 132.132.0.0

passive-interface fddi 0

distance 200 0.0.0.0 255.255.255.255

0 0

Post a comment