The Basic VPLS Configuration

The configuration for VPLS is simple. First, you must configure a VPLS instance with the global 12 vfi command. The VFI needs to have a unique name on the PE router.

Router(config)#l2 vfi name manual

Then you need to specify a unique VPN ID number for that VFI.

Router(config-vfi)#vpn id number

Configure as neighbors all the egress PE routers of the full mesh of that VPLS.

Router(config-vfi)#neighbor remote-router-id encapsulation mpls

After you define the VFI, associate the VLAN interfaces belonging to that VFI with the VFI. You do this with the interface command xconnect vfi.

Router(config-if)#xconnect vfi name

Consider the following VPLS network example depicted in Figure 11-6. Figure 11-6 VPLS Example Network cust-one

12 vfi cust-one manual vpn id 1

neighbor 10.100.100.1 encapsulation mpls neighbor 10.100.100.3 encapsulation mpls interface Vlan111 xconnect vfi cust-one

1

LON Metro Site

Loop back 0 10.100.100.1/32

12 vfi cust-one manual vpn id 1

neighbor 10.100.100.2 encapsulation mpls neighbor 10.100.100.3 encapsulation mpls interface Vlan111 xconnect vfi cust-one

Loop back 0 10.100.100.3/32

cust-one

12 vfi cust-one manual vpn id 1

neighbor 10.100.100.1 encapsulation mpls neighbor 10.100.100.2 encapsulation mpls interface Vlan111 xconnect vfi cust-one

Figure 11-6 shows three PE routers. Three sites are connected for the VPLS instance cust-one. The configuration of the PE router VPLS-PE-1 is shown in Example 11-1. VLAN 111 is associated with VPLS instance cust-one.

Example 11-1 VPLS Configuration of VPLS-PE-1

hostname VPLS-PE-1 !

mpls label protocol ldp mpls ldp router-id Loopback0 force l2 vfi cust-one manual vpn id 1

neighbor 10.100.100.2 encapsulation mpls neighbor 10.100.100.3 encapsulation mpls

interface FastEthernet4/2 no ip address switchport switchport access vlan 111 spanning-tree bpdufilter enable

interface POS5/1 ip address 10.10.1.1 255.255.255.0

mpls ip mls qos trust dscp

interface Vlan111 no ip address xconnect vfi cust-one

When the set of VFIs are configured on all PE routers for one VPLS customer, the VPLS instance is configured.

Micro Expression Master

Micro Expression Master

If You Could Read Everyone Life A Book You Can Have Better Career, Great Relationships And Become Successful. This Book Is One Of The Most Valuable Resources In The World When It Comes To Reading the smallest and tiniest body Language and know what people are thinking about.

Get My Free Ebook


Post a comment