Soo

PE-1

PE-1

MPLS-VPN Backbone

VPNv4 BGP Update SOO 1:100

VPNv4 BGP Update SOO 1:100

VPNv4 Route Is Not Put In VRF

MPLS-VPN Backbone

IGP or eBGP Update

This prevents possible routing loops, but it also prevents suboptimal routing. The suboptimal case that entails that for the routes local to the dual-homed sites, the path across the MPLS VPN backbone is preferred over the local path is blocked.

SOO is set in a route map, as shown in Example 7-36. Example 7-36 SOO Route Map Configuration route-map cust-one-soo permit 10 set extcommunity soo 1:100

If the SOO is applied for BGP, the route map is configured on the BGP neighbor command, as in Example 7-37.

Example 7-37 Applying SOO Route Map for BGP

router bgp 1

address-family ipv4 vrf cust

one

redistribute connected

neighbor 10.10.2.1 remote-as

65001

neighbor 10.10.2.1 activate

neighbor 10.10.2.1 route-map

cust-one-soo in

exit-address-family

!

If the SOO is applied for any routing protocol other than BGP, the route map is configured with the ip vrf sitemap command on the appropriate VRF interface, as in Example 7-38.

Example 7-38 Applying SOO Route Map on the VRF Interface interface Ethernet0/1/2 ip vrf forwarding cust-one ip vrf sitemap cust-one-soo ip address 10.10.2.2 255.255.255.0

You can also set the SOO for connected and static routes when they are redistributed into the IGP. Example 7-39 shows the redistribute command with an SOO route map.

Example 7-39 Applying SOO Route Map for Static Routes router bgp 1

address-family ipv4 vrf cust-one

Example 7-39 Applying SOO Route Map for Static Routes (Continued)

redistribute static route-map cust-one-soo neighbor 10.10.2.1 remote-as 65001 neighbor 10.10.2.1 activate exit-address-family i

Micro Expression Master

Micro Expression Master

If You Could Read Everyone Life A Book You Can Have Better Career, Great Relationships And Become Successful. This Book Is One Of The Most Valuable Resources In The World When It Comes To Reading the smallest and tiniest body Language and know what people are thinking about.

Get My Free Ebook


Post a comment