A3

On router D3, a point-to-point subinterface is configured so that the cost is set according to the PVC:

interface Serial4/1 no ip address encapsulation frame-relay cdp enable

interface Serial4/1.1 point-to-point ip address 10.1.3.126 255.255.255.252 ip ospf cost 390 (for 256K PVC) frame-relay interface-dlci 199

interface Serial4/1.2 point-to-point ip address 10.1.3.130 255.255.255.252

ip ospf cost 1785 (56k PVC) frame-relay interface-dlci 198

interface Serial4/1.3 point-to-point ip address 10.1.3.134 255.255.255.252 ip ospf cost 1562 (64K PVC) frame-relay interface-dlci 197

interface Serial4/1.4 point-to-point ip address 10.1.3.138 255.255.255.252 ip ospf cost 3125 (32K PVC) frame-relay interface-dlci 196

• Retransmit Interval

This is the amount of time between LSA retransmission for the adjacency on the interface, and it also can be used with DBD and LS request packets. This is useful when either the link or the remote router is slow, which causes the local router to retransmit packets repeatedly. The command to change the retransmission timer in Cisco is as follows:

ip ospf retransmit-interval seconds

The default value is five seconds. This value also appears in the output of show ip ospf interface command, as shown here:

Serial4/0.1 is up, line protocol is up Internet Address 10.1.1.2/30, Area 1 Process ID 1, Router ID 131.108.1.1, Network Type POINT_TO_POINT, Cost: 64

Transmit Delay is 1 sec, State POINT_TO_POINT, Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:05 Neighbor Count is 1, Adjacent neighbor count is 1

Adjacent with neighbor 10.1.23.1 Suppress hello for 0 neighbor(s)

• Transmit-Delay

This is the estimated amount of time to transmit an LSA out of this interface. The LSA in the update packet must be aged by this amount of time before transmission. This value must be greater than 0. In Cisco, this value is set to one second, by default. The command to change the interface transmit-delay is as follows:

ip ospf transm it-delay seconds

ID Router ID is used to identify a router; in Cisco implementation, it is the loopback interface address on the router. If the loopback is not configured, the highest IP address on the router is used.

This defines the area to which the router belongs and is defined along with the network command. Area characteristics are defined with the area command. The command is as follows:

router ospf 1

network 131.108.1.0 0.0.0.0 area 1 area 1 stub

For the previous configuration, area 1 is defined as a stub. For regular areas, only the network statement with an area is required.

• Hello/ Dead Interval

Hello is used to discover OSPF neighbors; Cisco defaults to 10 seconds on broadcast and point-to-point networks, and 30 seconds on non-broadcast multiaccess networks.

The dead interval is the amount of time a router waits for a hello packet before declaring the neighbor dead. Cisco defaults to 40 seconds on point-to-point and broadcast networks, and defaults to 120 seconds on NBMA networks.

Hello/Dead timers should match on all the routers that connect to a common subnet. Cisco has enhanced its implementation so that, by default, if a router misses four hello packets, the neighbor is declared dead. This can be a problem over slow links. OSPF sends periodic database updates, and this flooding of packets may cause the routers to miss hellos, causing loss of adjacency. The new enhancement causes the dead timer to reset every time the router receives a packet from the neighbor.

• OSPF priority

This is used to decide the designated router on the transit network. The router with the highest priority becomes the designated router, by default. When a router is elected as the designated router and a new router appears on the segment with a higher priority, the new router cannot force election and must accept the designated router.

To force the election of a new designated router, you must remove the existing designated and backup designated routers from the segment. A router with zero priority can never be elected as the designated router. The OSPF priority command is as follows:

ip ospf priority value

Was this article helpful?

0 0

Post a comment