Physical Layout and Prestaging

• Connect the hubs and serial cables to the routers, as shown in Figure 17-8. Use HDLC as the WAN protocol.

• Connect the three Ethernet hubs to the routers to form three LAN segments, as shown in Figure 17-8.

• Configure EIGRP across the network, use 2001 as the Autonomous System ID.

• Add and configure the NTP server on the Ethernet segment of the ticket_central router. Enable NTP broadcast, and set the stratum level to 3 on the software. The IP address of the server is 206.191.241.45.

Lab 35: Configuring NTP Servers, Clients, and Peer Associations—Part II

Lab Walkthrough

After completing the physical installation of the LAN and WAN segments, you should establish IP connectivity among all the routers. Before trying to configure NTP, be sure to perform source pings from each router's Ethernet to verify end-to-end connectivity.

Beginning with the ticket_central router, configure the IP address of the E0 port and the two serial ports. This end is the DCE side of the serial link, so a clock rate command is needed; use the clock rate 56000 command on the S0 and S3 interfaces. The WAN protocol is HDLC, so you will not need to configure an encapsulation type on this link.

On the metallica and pearl_jam routers, you need to configure an IP address on the E0 ports and the S0 ports. When the IP addresses are configured and the links are brought up, you should be able to ping other routers' serial ports.

When the interfaces are up, configure EIGRP on all the routers, and use the autonomous System ID of 2001. Example 17-26 lists the relevant IP configuration for the all the routers in the lab.

Example 17-26 Relevant IP Configuration for the Routers in This Lab hostname ticket_central !

interface EthernetO ip address 206.191.241.43 255.255.255.248

interface SerialO ip address 172.10.128.1 255.255.255.252 no fair-queue clockrate 56000

interface Serial3 ip address 172.10.128.5 255.255.255.252 clockrate 56000

router eigrp 2001 network 206.191.241.0 network 172.10.0.0

hostname pearl_jam !

interface EthernetO ip address 172.10.33.1 255.255.255.0

interface SerialO ip address 172.10.128.6 255.255.255.252 no ip directed-broadcast no ip mroute-cache no fair-queue

router eigrp 2001 network 172.10.0.0

hostname metallica

interface Ethernet0 ip address 172.10.32.1 255.255.255.0

interface Serial0 ip address 172.10.128.2 255.255.255.252 no ip directed-broadcast no ip mroute-cache no fair-queue

router eigrp 2001 network 172.10.0.0

To configure NTP on the ticket_central router, you must configure it as a both a client and a master. First, use the ntp server 206.191.241.45 command to point to the NTP server off its E0 port. At this time, you can also configure this router as an NTP master. To accomplish this, use the ntp master command. There is no need to add a stratum because you want to preserve the stratum number that the NTP server broadcasts. The last step is to set the time zone to Pacific time, with an 8-hour offset. This is done by using the clock timezone PAC -8 command. Example 17-27 lists the NTP configuration of the ticket_central router.

Example 17-27 NTP Configuration of ticket_central ticket central(config)#clock timezone PAC -8 ticket_central(config)#ntp server 206.191.241.45

ticket central(config)#ntp master

Check the status of NTP by using the show ntp status command. Look for the clock to be synchronized; it should have a reference clock of 206.191.241.45.

Finally, you can configure the NTP peer associations on the metallica and pearl_jam routers. Use the ntp peer 172.10.128.1 and ntp peer 172.10.128.5 commands, respectively, on these routers. Use the same clock timezone PAC -8 command to set the time zone to Pacific time.

Use the show ntp status and show ntp associations commands on the remote routers to verify NTP synchronization. Example 17-28 lists the output of these commands on the metallica router.

Example 17-28 Verifying NTP Synchronization metallica#show ntp status

Clock is synchronized, stratum 5, reference is 172.10.128.1

nominal freq is 250.0000 Hz, actual freq is 250.0010 Hz, precision is 2**19 reference time is BD1D1551.469209A4 (21:17:05.275 PAC Sun Jul 16 2000) clock offset is -10.3164 msec, root delay is 34.47 msec root dispersion is 70.31 msec, peer dispersion is 3.92 msec metallica#

metallica#show ntp associations address ref clock st when poll reach delay offset disp

*~172.10.128.1 206.191.241.45 4 39 64 377 30.3 -10.32 3.9

* master (synced), # master (unsynced), + selected, - candidate, ~ configured metallica#

Notice that the reference clock in the show ntp associations command is that of your original NTP server, 206.191.241.45. The stratum of 5 indicates that the stratum is being passed and incremented from the original NTP server.

The optional part of this exercise consists of preventing NTP broadcasts on the Ethernet segments of the remote routers. To disable NTP broadcasts of any interface on a router, use the ntp disable command under the interface that you want to disable the broadcast from entering. Example 17-29 lists the configurations of the metallica and pearl_jam routers.

Example 17-29 Configurations of the metallica and pearl_jam Routers hostname metallica !

clock timezone PAC -8 !

interface Ethernet0

ip address 172.10.32.1 255.255.255.0 ntp disable

interface Serial0 ip address 172.10.128.2 255.255.255.252 no ip directed-broadcast no ip mroute-cache no fair-queue

router eigrp 2001 network 172.10.0.0

ntp clock-period 17179749 ntp peer 172.10.128.1

hostname pearl_jam ! !

clock timezone PAC -8 !

interface Ethernet0 ip address 172.10.33.1 255.255.255.0 ntp disable

interface Serial0 ip address 172.10.128.6 255.255.255.252 no fair-queue

router eigrp 2001 network 172.10.0.0

ntp clock-period 17179636 ntp peer 172.10.128.5

Was this article helpful?

0 0

Post a comment