Example 166 Complete Configuration of the walkerl Switch

hostname walker1

i enable secret 5 $1$oTsK$C95mG2YeDzQ4w3ecs0CkS0 i ip subnet-zero ip routing spanning-tree mode mst spanning-tree extend system-id i spanning-tree mst configuration name walker revision 1

instance 1 vlan 2-300

i spanning-tree mst 1 priority 24576 i

<<<text omitted>>> i interface FastEthernet0/3 switchport access vlan 300 switchport mode access no ip address spanning-tree portfast i

<<<text omitted>>> i interface FastEthernet0/5 switchport access vlan 100 switchport mode access no ip address spanning-tree portfast i

interface FastEthernet0/8 switchport access vlan 100 switchport mode access no ip address spanning-tree portfast

interface FastEthernet0/10 switchport access vlan 20 switchport mode access no ip address spanning-tree portfast

interface FastEthernet0/11 switchport access vlan 20 switchport mode access no ip address spanning-tree portfast

interface FastEthernet0/12 switchport access vlan 20 switchport mode access no ip address spanning-tree portfast

interface FastEthernet0/13

switchport access vlan 20

switchport mode access

no ip address

spanning-tree portfast

!

interface FastEthernet0/14

switchport access vlan 20

switchport mode access

no ip address

spanning-tree portfast

!

interface FastEthernet0/15

switchport access vlan 20

switchport mode access

no ip address

spanning-tree portfast

!

<<<text omitted>>> i

interface FastEthernet0/17

switchport trunk encapsulation

dot1q

switchport mode trunk

!

interface GigabitEthernet0/2

switchport trunk encapsulation

dot1q

switchport mode trunk

no ip address interface Vlanl no ip address shutdown i interface Vlan20 ip address 172.16.2.16 255.255.255.0

i interface Vlan100 ip address 172.16.10.16 255.255.255.0

i interface Vlan192 ip address 172.16.192.16 255.255.255.0

i interface Vlan300 ip address 172.16.30.16 255.255.255.0

i router eigrp 2003 network 172.16.0.0 auto-summary no eigrp log-neighbor-changes i ip classless ip http server i line con 0

line vty 5 15

i end

walker1#

walker1#show ip eigrp neighbors

IP-EIGRP neighbors for process 2003

H Address Interface Hold Uptime

SRTT

RTO

Q

Seq Type

( sec )

(ms)

Cnt

Num

3 172.16.10.5 Vl100 14 00:03:02

1048

5000

0

5

2 172.16.30.3 Vl3 0 0 12 00:03:04

1

3000

0

9

1 172.16.30.7 Vl3 0 0 13 00:03:06

1208

5000

0

10

0 172.16.10.8 Vl100 14 00:03:06

1516

5000

0

9

walker1#

0xample 1-c7 lis ts te|ev ant config urat ion porti ons of th e walkef2

tshwaittcghu

Example 1-67. walker2 Switch Configuration

i

enable secret 5 $1$oTsK$C95mG2YeDzQ4w3ecs0CkS0 i

spanning-tree mode mst

spanning-tree extend system-id i

spanning-tree mst configuration

name walker

revision 1

instance 1 vlan 2-300

interface FastEthernet0/1 switchport access vlan 300 switchport mode access no ip address spanning-tree portfast

interface FastEthernet0/17 switchport trunk encapsulation dotlq switchport mode trunk no ip address

interface GigabitEthernet0/2 switchport trunk encapsulation dot1q switchport mode trunk no ip address

interface Vlanl no ip address shutdown

interface VLAN192 ip address 172.16.192.13 255.255.255.0 no ip directed-broadcast no ip route-cache

ip default-gateway 172.16.192.16

The final portion of the lab requires that you control access on VLAN 20. To prevent the administra' workstation from using IP services between them, you can define them as protected ports. Recall t a protected port prevents other ports that are protected from communicating with it. A protected p can still reach other nonprotected ports on the switch. Example 1-68 demonstrates the configuratk of the protected ports with the range command.

Was this article helpful?

0 0

Post a comment