Configuring Ospf Abrs

Cisc-o.com

R1(config)# router ospf 50

R1(config-router)# network 172.16.14.1 0.0.0.0 area 0

R1(config)# router ospf 50

R1(config-router)# network 172.16.14.1 0.0.0.0 area 0

R4(config)# router ospf 50

R4(config-router)# network 172.16.14.4 0.0.0.0 area 0 R4(config-router)# network 172.16.45.4 0.0.0.0 area 4

R4(config)# router ospf 50

R4(config-router)# network 172.16.14.4 0.0.0.0 area 0 R4(config-router)# network 172.16.45.4 0.0.0.0 area 4

© 2002, Cisco Systems, Inc. All rights reserved.

Cisco CCIE Prep v1.0—Module 7-39

There are no special commands to make a router an Area Border Router (ABR) or Autonomous System Boundary Router (ASBR). The router assumes this role by virtue of the areas or autonomous systems to which it is connected. If a router has interfaces in different OSPF areas, it is an ABR. If the router has an interface in OSPF and an interface in another routing protocol and is performing redistribution of that protocol into OSPF, it is an ASBR.

sco.com sco.com

© 2002, Cisco Systems, Inc. All rights reserved.

Cisco CCIE Prep v1.0—Mod

S0/2

S0/0

S0/0

172.16.14.1

Area

© 2002, Cisco Systems, Inc. All rights reserved.

Cisco CCIE Prep v1.0—Mod

In the example above, Area 4 is configured as a stub area. No external routes (Type 5 LinkState Advertisements (LSAs)) from the external autonomous systems (other routing domains) will be allowed into the stub area.

The area 4 stub command on each router in Area 4 defines the stub area. Each router in the stub area must be configured with the area 4 stub command or neighbor adjacencies will not be formed.

Table 6-10: < area <area-id> stub > Command

Command

Description

area <area-id> stub

Designates this router as part of a stub area. Performed in router configuration mode.

The only routes that will appear in R4's routing table are intra-area routes (designated with an O in the routing table), inter-area routes, and the default route (these routes will be designated with an O-IA in the routing table).

Ospf Router Types

In this example, the keyword no-summary has been added to the area 2 stub command on R3. This keyword causes summary routes (inter-area Type 3/4 LSAs) to also be blocked from the stub area. Each router in the totally stubby area will pick the closest ABR as a gateway to get to any destinations outside of the area. The only routes that will appear in R4's routing table now are intra-area routes (designated with an O in the routing table) and the default route. No inter-area routes (designated with O-IA in the routing table) will be shown, except the default route.

Table 6-11: < area <area-id> stub no-summary > Command

Command

Description

area <area-id> stub no-summary

Prevents an ABR from sending summary link advertisements into the stub area. Use this keyword to create a totally stubby area. Performed in router configuration mode.

Note The no-summary keyword is only required on the ABRs connected to the totally stubby area. The internal routers within the stub area only need to be configured with the area stub command.

OSPF Not-So-Stubby Area (NSSA) Introduction

-isco.com

R5(config)# router rip R5(config-router)# network 10.0.0.0 R5(config)# router ospf 50

R5(config-router)# network 172.16.45.5 0.0.0.0 area 4

R5(config-router)# area 4 nssa R5(config-router)# redistribute rip subnets

-isco.com

R4( config) ft router

ospf 5O

R4(config-router)ft

network

l72

le

45.4 O.O.O.O area 4

R4(config-router)ft

network

l72

le

l4.4 O.O.O.O area O

R4(config-router)ft

area 4 n

ssa

no

summary

© 2002, Cisco Systems, Inc. All lights reserved.

Cisco CCIE Prep v1.0—Module 7-42

In the network diagram above, Area 4 is defined as a stub area. R5 also connects to a Routing Information Protocol (RIP) network and therefore qualifies as an ASBR. However, the RIP routes cannot be propagated into the OSPF domain, because Type 5 LSAs are not allowed into a stub area. In order to redistribute RIP information into OSPF here, we must define area 4 as a special type of stub area called a not-so-stubby area (NSSA).

Since Type 5 LSAs are not allowed into a stub area, the NSSA ASBR generates Type 7 LSAs instead, which are flooded throughout the NSSA. The Type 7 LSAs get translated into Type 5 LSAs by the NSSA ABR and are propagated into the OSPF backbone. Redistributed Enhanced Interior Gateway Routing Protocol (EIGRP) and Interior Gateway Routing Protocol (IGRP) routes from other areas in the network are still not allowed into area 4, because a NSSA is just an extension to the stub area, and all the characteristics of a stub area still exist, including disallowing Type 5 LSAs.

Table 6-12: < area <area-id> nssa no-summary > Command

Command

Description

area <area-id> nssa no-summary

Configures a stub area that contains an ASBR to allow external routes into the stub area as Type 7 LSAs. The no-summary keyword is used to create a totally stubby NSSA. Performed in router configuration mode.

R5(config)# router ospf 50

R5(config-router)# network 172.16.45.5 0.0.0.0 area 4

R5(config-router)# area 4 nssa no-redistribution

R5(config-router)# redistribute rip subnets

R5(config-router)# exit

R5(config)# router rip

R5(config-router)# network 10.0.0.0

R5(config)# router ospf 50

R5(config-router)# network 172.16.45.5 0.0.0.0 area 4

R5(config-router)# area 4 nssa no-redistribution

R5(config-router)# redistribute rip subnets

R5(config-router)# exit

R5(config)# router rip

R5(config-router)# network 10.0.0.0

R4(config)# router ospf 50

R4(config-router)# network 172.16.45.4 0.0.0.0 area 4 R4(config-router)# network 172.16.14.4 0.0.0.0 area 0 R4(config-router)# area 4 nssa no-summary

R4(config)# router ospf 50

R4(config-router)# network 172.16.45.4 0.0.0.0 area 4 R4(config-router)# network 172.16.14.4 0.0.0.0 area 0 R4(config-router)# area 4 nssa no-summary

o CCIE Prep v1.0—Module 7-43

NSSA no-redistribution can be used to stop redistributed Type 7 routes from being flooded in the NSSA area.

Further, no-summary can be added to stop Type 3/4 LSAs from being distributed except for the default route Type 3 summary.

Table 6-13: < area <area-id> nssa no-redistribution > Command

Command

Description

no-redistribution

(Optional) Used when the router is an NSSA Area Border Router (ABR) and you want the redistribute command to import routes only into the normal areas, but not into the NSSA area. Performed in router configuration mode.

Was this article helpful?

0 -3

Post a comment