Scenario 51 Answers

1 Design the addressing scheme for the site so that summarization can be implemented at a later stage.

An addressing scheme for the Los Angeles site could be as shown in Figure 5-14.

2 Determine the configuration that will be implemented across the Frame Relay cloud.

The Frame Relay configuration is a hub-and-spoke topology. Because Los Angeles is the central hub of the company, it is logical that it is also the network hub.

The configuration in Frame Relay would therefore be a point-to-multipoint one. This avoids the DR/BDR election process because it treats all the PVC links as a collection of point-to-point links, therefore removing the need for the DR/BDR. This is a good solution if the three different companies have a multivendor environment because it conforms to the RFC standards.

Figure 5-14 Scenario 5-1 Answer

Figure 5-14 Scenario 5-1 Answer

Example 5-14 shows a configuration that could be implemented.

Example 5-14 Scenario 5-1 Configuration Question #2 Answer

Los Angeles interface serial 0

encapsulation frame-relay ip address 10.255.0.35 255.255.255.248

ip ospf network point-to-multipoint router ospf 100

network 10.0.0.0 0.255.255.255 area 0

continues

Example 5-14 Scenario 5-1 Configuration Question #2 Answer (Continued)

San Francisco interface serial 0

encapsulation frame-relay ip address 10.255.0.36 255.255.255.248

ip ospf network point-to-multipoint router ospf 100

network 10.0.0.0 0.255.255.255 area 0 London interface serial 0 encapsulation frame-relay ip address 10.255.0.37 255.255.255.248 ip ospf network point-to-multipoint router ospf 100

network 10.0.0.0 0.255.255.255 area 0

If individual point-to-point networks are chosen, then a separate PVC and IP subnet will be required for the configuration. This is illustrated in Example 5-15.

Example 5-15 Scenario 5-1 Configuration Question #2 Answer

Los Angeles interface serial 0 no IP address encapsulation frame-relay interface serial0.1 point-to-point ip address 10.255.0.35 255.255.255.252 frame-relay interface-dlci 21 interface serial0.1 point-to-point ip address 10.255.0.49 255.255.255.252 frame-relay interface-dlci 28

router ospf 100

network 10.0.0.0 0.255.255.255 area 0

San Francisco interface serial 0

no IP address encapsulation frame-relay interface serial0.1 point-to-point ip address 10.255.0.36 255.255.255.252

frame-relay interface-dlci 44

router ospf 100

network 10.0.0.0 0.255.255.255 area 0 London interface serial 0 no IP address

Example 5-15 Scenario 5-1 Configuration Question #2 Answer (Continued)

encapsulation frame-relay interface serial0.1 point-to-point ip address 10.255.0.50 255.255.255.252 frame-relay interface-dlci 66

router ospf 100

network 10.0.0.0 0.255.255.255 area 0

Note that the Frame Relay cloud is a continuation of Area 0. This is a logical first step; it is advisable to change this configuration when OSPF is being run throughout the organization. When the other sites are up and running OSPF, Los Angeles site could become another area. This would allow the summarization of routes across the Frame Relay cloud, which would reduce the traffic, cost, and possibility for congestion.

3 State the configuration commands required to implement OSPF on the routers. Note that all the routers are to be in Area 0.

The configuration on the Los Angeles routers, not including the Frame Relay configuration, is shown in Example 5-16.

Example 5-16 Scenario 5-1 Configuration Question #3 Answer

Router A: router ospf 100 network 10.0.0.0 area 0

ip address 10.1.1.65 255.255.255

ip ospf priority 10

224

Router B: router ospf 100 network 10.0.0.0 area 0

ip address 10.1.1.66 255.255.255

224

interface ethernet 1

ip address 10.1.2.1 255.255.255.0

Router C router ospf 100 network 10.0.0.0 area 0

ip address 10.1.1.67 255.255.255

224

interface ethernet 1

ip address 10.1.3.0 255.255.255.1

Note that Router A has been given a priority of 10, ensuring that it becomes the DR. Although this is not essential, it is a clear configuration and is advisable because this router is a larger system and very reliable. For the same reasons, it is also considered good system management to define the priority for the BDR.

Was this article helpful?

0 0

Post a comment